AnsweredAssumed Answered

In Chrome hide the web viewer scroll bars

Question asked by justinc on Nov 22, 2016
Latest reply on Dec 6, 2016 by justinc

I'm running into an issue with how a web viewer object renders inside Chrome.  It seems to work fine on Safari and in FileMaker.  This is viewed through Web Direct obviously.

 

FMS 15.01

Client - OS X 10.11.6

FMPA 15.02

Chrome 54.0

Safari 10.0.1

 

I have a small web viewer in which I'm trying to render a small image to act as a button.  That's the only thing in it - no need to scroll anything.  I just want a small unobtrusive widget on my layout for this button.  (Using a button in the web viewer allows for better handling of a new-window function on this button - it opens a new tab/window and points at another website entirely, so don't want to trample the current Web Direct session.)  Even just using a simple anchor tag with text causes Chrome to show scroll bars.

 

Here's how it looks in FileMaker:

Screen Shot 2016-11-22 at 15.36.02 .png

 

In Safari:

Screen Shot 2016-11-22 at 15.35.40 .png

 

And in Chrome:

Screen Shot 2016-11-22 at 15.35.53 .png

 

This object on the layout is 200wx150h; I made it large for testing purposes, to try and ensure it was large enough for the HTML elements.

 

I've tried numerous CSS tricks to try and get the scroll bar to go away, so now I'm hoping that someone has done this before and has the answer.

Here is the code I have currently:

 

"data:text/html,

<!DOCTYPE html>

 

<script type=\"text/javascript\">   

    function clickA() {

        var newWindow = window.open('http://some.web.site/')

            return false;

    }

</script>

<style>

html {

    height: 30px;

    width: 200px;

    overflow: hidden;

}

 

Body::-webkit-scrollbar {

     display: none;

     -ms-overflow-style: none;

}

 

#HideScrollBarinChromeWrapperDiv {

    overflow: hidden;

}

 

</style>

<html><body>

<div id=\"HideScrollBarinChromeWrapperDiv\">

    <a href=\"#\" id=\"SomeLink\">Some Link</a>

</div>

 

<script type=\"text/javascript\">   

    document.getElementById('SomeLink').onclick = clickA;

</script>

 

</body></html>"

 

The link/button in the web viewer functions as desired...I'm just trying to get the 'look' down now.  Normally I might consider just telling clients to use Safari...but Safari has a bug where 5 minutes of idle-time causes the user to lose connection with Web Direct, regardless of the FMS setting.

 

Thanks,

J

Outcomes