6 Replies Latest reply on Nov 25, 2016 4:09 PM by PaulKneipp

    Troubleshooting client disconnections FMS14

    PaulKneipp

      How can I troubleshoot disconnections for FMP clients to a server at a university campus? The scenario:

       

      The machine is in the university campus server room - very fast connection to the web.

      Windows 8 running FMS14

      Clients are using Server Connection software or WebD, on Windows 7

       

      At home, I often connect to the server from my MacBook and leave it open all day (in use) I NEVER have disconnections. I can use my phone the same way. WebD is super solid. But when tutors use the database on campus - so they are physically 200 metres from the box - they get disconnected every 15 minutes. It's driving me mad. The on-site IT don't understand what I am asking them. This has only happened this semester - last semester there was no issue. No upgrades since then. I am about to move the hosting to a university hosted VM running Windows 2012, allowing the upgrade to FMS15. But what if I do that and the local campus still has disconnections? This is when they are actually using the databases, not just logging in and leaving the room. They are sitting marking assessments and they get the popup box (see picture)

       

      Please advise what logs to look at in more detail, as currently the server messages just say lost connection. Very frustrating. Thanks for your time - it's much appreciated.

        • 1. Re: Troubleshooting client disconnections FMS14
          mardikennedy

          I haven't been in that specific situation myself but the first place I'd look would be Priv Sets.  Do the tutors use a different priv set to yours?  It may be that their priv set is set to disconnect (File/ Security/ Privilege Sets) whereas yours is not set to disconnect.  HTH.

          • 2. Re: Troubleshooting client disconnections FMS14
            PaulKneipp

            Would you believe that's the <only> file that had "require re-authentication . . . " ticked in the Full Access box. I had one lecturer with disconnects at another file - I had checked that section but this is a new file! What a dope. Thanks very much. I will ask someone to test this now and see what happens. My question now is - they are using the "Full Access" set - and so am I. Why wasn't I asked for re-authentication on the Mac?

             

            Thanks so much for your help - it's really appreciated.

            • 3. Re: Troubleshooting client disconnections FMS14
              mardikennedy

              Pleased it worked.

               

              Not sure why the inconsistencies; perhaps, because it can be one priv set yet behave differently on different devices ie FMP/ FM Go.  Any chance that either of the Full Access users was actually using an iPad? 

               

              Also, are you certain that you want multiple users to have Full Access?  Naturally that's a decision that's entirely particular to your environment and needs, but restrictions are sometimes a good idea.

              • 4. Re: Troubleshooting client disconnections FMS14
                PaulKneipp

                Certainly I will be restricting permissions again. I was in a desperate situation, so I turned them off. The layouts they can see are limited and locked up fairly tightly, so they can really only enter data anyway. I have asked for a test (I'm not on campus) If it seems normal, then I will change them to a different privilege set, as you recommend. Just odd that it doesn't do it on a MacBook . . . it's as though using the administrator login, even with the same privilege set, bypasses that?

                • 5. Re: Troubleshooting client disconnections FMS14
                  PaulKneipp

                  Unfortunately, that makes no difference. A lecturer said that it still disconnected.

                  • 6. Re: Troubleshooting client disconnections FMS14
                    PaulKneipp

                    Mystery solved. Thanks to Tim from FileMaker Support here in AU. Tim picked up after thinking about our conversation that I had distributed the vs 15 client connection version of FileMaker to users who were then connecting to a vs 14 database. Yes, I did feel dumb. I had only been using WebD and sent the software to a few users. It was asking for a license, not dropping the connection. You cannot obviously use the new client connect protocol with vs 14, since it was not designed for 14. I'm actually very relieved and I can look forward to the new hosting setup with confidence. Thanks Tim - and all who did try to help.