4 Replies Latest reply on Nov 28, 2016 3:14 AM by adam_darren

    Filemaker Go importing

    adam_darren

      Hi all,

       

      Is it at all possible to import records from a filemaker DB on go with another database on Go. For example, can I email my DB to a customer and can they open that database and import the information from it to an existing DB on their iphone using Go?

       

      I know you cannot import CSV files and the like, but I have done a lot of reading and supposedly you can import records into Go as long as it is from another filemaker DB. Most of the items I have been reading relate to importing from a remote source, but I want to import locally. As in, on the same device.

       

      I have tried several ways to set a variable:

       

      $file; Value: get(documentspath) & "source.fmp12"

      Import Records [No dialog; "$file"; Add; Windows ANSI]

       

      When I try running the script on the import file, I get an error saying that the file could not be opened. I have searched for hours and cannot see what mistake I am making.

       

      Thanks


      Darren

        • 1. Re: Filemaker Go importing
          skywillmott

          Your script step to set the $file variable can just be:

           

          Set Variable [ $file; Value: "file:source.fmp12"]

           

          ... And make sure that in the 'Import Records..." script step you set the File Type in the 'Specify File' options to 'FileMaker Pro Files' - this is essential to do for Filemaker Go as otherwise import doesn't work for some reason, even if set to 'All Available'... See attached screenshot.

           

          import.png

           

          Hope this helps :-)

          • 2. Re: Filemaker Go importing
            rgordon

            Is the source.fmp12 file password protected?  If yes , this might be the cause of your problem since the file with the script can not open the file.

            • 3. Re: Filemaker Go importing
              adam_darren

              Hi guys,

               

              Thank you for your responses.

               

              I can confirm that the file is not password protected.

               

              I have made the alterations suggested by SkyWillmott, but I am still receiving the error on the iphone that the file cannot be found. It is strange, as it works fine on the computer. One thing I did notice though, where you said change the file type to Filemaker Pro Files, I don't have that exact option. Instead I have "Filemaker Files (*.FMP12)". I don't think this should matter though. I have Filemaker Pro Advanced.

               

              I have tried to delete the app from my phone and re-download from the App Store. But I still get the same error message.

               

              I then went and made a script to simply open the source file, and this worked fine. So the file can be seen. But when I try and do the import, I get the same error message which is:

               

              ERROR: The file "Source.fmp12" could not be opened. (Not Found).

               

              I thought maybe it could be a security setting, but that also never worked. (I added another account).

               

              I'm sure there is a reason.......I just don't know it.

               

              Thanks again for your help.

               

              Regards

               

              Darren

              • 4. Re: Filemaker Go importing
                adam_darren

                Hmmm, that's a bit embarrassing.

                 

                I really didn't want to say anything, but anyway, honesty is the best policy I guess.

                 

                After hours of searching, and downloading other people's sample database and looking at it......it turns out there is a difference between the word "Source.fmp12" and "source.fmp12"......oops.

                 

                It works now.

                 

                Sorry for the muck around.

                 

                Regards

                 

                Darren