2 Replies Latest reply on Dec 8, 2016 6:50 PM by taylorsharpe

    FM Go 15 Variables Corruption

    taylorsharpe

      I ran into an interesting situation at a client that does a lot of barcoding via a bluetooth scanner connected to a large iPad in a warehouse using FM Go 15 connected to a FileMaker server 15.0.3 and somehow the FM Go became corrupt with the global variables, substituting them randomly.  So we closed the file and opened it again (did not quit FM Go, only closed and opened the file) and it still had the same problem.  Not until we actually quit the FM Go application and started it back up again would it work.  It was very weird to watch run scripts that would set variables, and it was setting them, but it was switching which values went with which global $$ variable in what seemed a random fashion.  At first I thought it was my scripts and while it was doing this, we were testing it both on my FMPA 15 and another iOS device and neither of them had the same issues.  It may have been just a very strange glitch.  Everything else seemed fine like opening and closing the file and navigating around in layouts, editing records, etc.  Only global $$ variables were not working correctly.  After restarting the app, everything went back to working fine.  If that hadn't worked, we were going to reboot the iPad, but never got to the point of needing to try that.  But I thought I'd post this weird variable situation just in case someone else has seen this happen before on FM Go.

        • 1. Re: FM Go 15 Variables Corruption
          philmodjunk

          This should be posted as a Product Issue Report (click Home above to get to the page from which you can make such a report) to bring it to the attention of the FileMaker Techs that manage that part of this community.

          1 of 1 people found this helpful
          • 2. Re: FM Go 15 Variables Corruption
            taylorsharpe

            philmodjunk wrote:

             

            This should be posted as a Product Issue Report (click Home above to get to the page from which you can make such a report) to bring it to the attention of the FileMaker Techs that manage that part of this community.

             

            Yes, good point, but I thought I'd see if anyone has seen this before posting it.  I'm reluctant to raise a product issue unless it seems to be happening more than this one time or else I'm easily able to reproduce it, which I am not at this time.