3 Replies Latest reply on May 18, 2017 10:04 PM by mardikennedy

    Filemaker Server iMac loses network connect when Pro used to upload

    wendy

      Product and version:   Filemaker Server 15.0.3.308


      OS and version: Mac OS 10.11.6 (El Capitan)

      Hardware: 27-in Imac, 3.2GHz Intel Core i3 processsor, 16 GB 1333 MHz DDR3, ATI Radeon HD 5670 512 MB

      
 

      Description: iMac server loses Ethernet network connectivity (to a mounted file server, to Internet, and connectivity for remote clients) shortly after Filemaker Pro on the server is used to upload files to the database server. The FM server itself appears to continue to run just fine. Issue does not occur if Pro on a remote client machine is used to upload the files.

      
 

      How to replicate:

      - Start iMac server.


      - Optional: Mount a corporate network drive. (I do this because the iMac shows a prominent alert at the time the mounted drive is disconnected. Having a drive mounted is not required for the issue to occur.)


      - Start Admin console and log in.


      - Start up the server (status tab).


      - Start Filemaker Pro at the iMac server.


      - Via Filemaker Pro, upload healthy database files (we have them in a folder on the server desktop) to the server. (Note: Pro on the server always shows it is doing consistency checks, although files have been closed properly.)


      - After the upload is completed, Pro is still running in the background. Within a minute or a few minutes, an alert appears from the iMac: "Server connections interrupted: [mounted drive name], Ignore/Disconnect All."


      - Clients unable to access the served files. iMac server is unable to reach the internet or re-mount the network drive. Server itself appears fine. 


      - Throughout this issue, the Ethernet Network System Preference remains green/connected.

      - A reboot is required to re-establish network connectivity.


       

      Notes:

      - In additional tests, the disconnect occurred as I quit out of FMPro. Quitting Pro immediately after the upload is finished still triggers the disconnect.


      - Cabling and network verified by I.T.

      - Our previous FM 13 Server iMac did not experience the problem while at this same location using the same network cable/hookup/outlet.

      - Same problem occurs if this FM 15 Server iMac is at a different location using a different cable and network hookup/outlet.

      - This FM 15 Server iMac was stable and experienced no disconnect issues while simply left running for three weeks (with the network drive mounted also).


      - Other activity at the server (e.g. connecting to the internet and logging this bug) did not cause connection issues.


      - In the decade+ we've been using Filemaker, we've always used a local copy of Pro, running on the server itself, to upload files to the server. Per call to FM tech support today, this shouldn't be an issue. (We do NOT use this copy of Pro to actually work on files.)


       

      Workaround:

      - Use a remote client running FMPro/Adv 15 to upload the files to the server.

        • 1. Re: Filemaker Server iMac loses network connect when Pro used to upload
          TSGal

          wendy:

           

          Thank you for your post.

           

          I found your Technical Support case, and it appears the Support Technician is still working with you on this issue.  Please continue to work with him.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: Filemaker Server iMac loses network connect when Pro used to upload
            wendy

            TSGal, I tried the following as suggested by the support technician:

             

            1) Reboot into Safe mode. Result: I could not access the console after trying this. Using the command line to launch FM components did not alter this result.

             

            2) Look for items in System Prefs>Account>Login Items. Result: There is nothing in the Login area. This was a very clean install of the OS to a newly formatted hard drive, followed by the FMS installation and nothing else.

             

            We went live last night with a FM13 > FM15 upgrade and have enountered serious issues, so I may not be able to respond further on this for a while.

            • 3. Re: Filemaker Server iMac loses network connect when Pro used to upload
              mardikennedy

              Virtually the same specs on a test server except with an install of FMS 16 (not FMS 15).  Uploading to the Mac-hosted FMS install from a Windows 7 WS is fine.  (Used FMPA 16; haven't tested with FMPA 15)

               

              Trying to upload from the local Mac doesn't work.  At all.  Tried FMPA 15 first - hung before entering the server credentials.  Installed FMPA 16 - did not allow clicking into the server credentials fields.  Irritating.  The obvious workaround is to shift the file(s) to be uploaded to a Windows WS (probably less inconvenient than manually copying a solution with externally stored containers into the FMS install), but would be nice if it was not necessary.