13 Replies Latest reply on Dec 15, 2016 9:58 AM by BeatriceBeaubien

    Set Field command not working on FileMaker Server

    Heine

      Hi all!

       

      I'm registering some odd behaviour with at script I'm trying to run from FileMaker Server 14.

       

      I'm doing a search for some records using:

       

      Enter Find Mode

      Go To Layout [Layout Name]

      Set Field [1] ... Value

      Set Field [2] ... Value

      Perform Find

       

      Now, the first Set Field[1] value is just a '1'. The field itself is a numeric, indexed field and everything works just fine entering the '1'

      Set Field[2] is different. I want to find all values greater than or equal to 1, so I use "≥1" - entered as shown. The field itself is an unstored calc, showing data as numbers.

       

      If I run the script on my MacBook Pro running FMA 15, everything just sings.

       

      If I set up a schedule on my Server 14, running on a fairly new Mac Mini, the script exits at the Set Field[2] with a 401 error message. When I disable Set Field[2], everything sings on the server too. I can do a workaround and get to the result that I want without the Set Field[2] script step, but I'm curious as to WHY Server 14 does not like the "≥1" that I put in as a find criteria!

       

      Any ideas?