Vincent_L

Committing manage database changes is seriously broken

Discussion created by Vincent_L on Dec 21, 2016
Latest reply on Dec 28, 2016 by TSGal

Hi,

 

I've already reported that I suffers trouble with my FMS 15v3 hosted solution when committing manage database changes.

So today, during the lunch break (when nobody works), I stoped all server side scripting, I kept the connected client that are just doing nothing.

I also stopped backup schedules

Then I did my changes, I added 3 fields, modified 2 more. I did this on a client that run on the same mac as FMS (to avoid networking latency).

Then I clicked ok to commit my changes… it's been 1 hour and it still not done, but the worst part is that  both Filemaker client and FMS appears to do absolutely nothing : CPU percentage = 0% on all filemaker and fms process.

 

S I disconnected all idle clients, but then 20 minutes later still the same thing. So If a locked record by a client could have explained the locking eventually, at least the process is not resuming when all other clients are disconnected

 

So basically Filemaker is locks,the clients also locks the GUI, but Filemaker is doing nothing, it's iddle !!!!

 

I can understand that the task to commit those change may be big, but then CPU usage should be to the roof.

FIX THIS

 

Oh, and by the way, now, my clients can't log again

 

Thanks

 

Attached are 60 seconds samples of both the fmserved process, and the FMPa one.

I want to know what is doing fms and FMPa, thanks

 

Dropbox - FilemakerOnStrike.zip

Outcomes