2 Replies Latest reply on Jan 14, 2017 10:03 AM by reggleton

    AVPlayer ignoring start position except when allowed to start in full-screen

    reggleton

      I am wanting to play a video within a container field window i.e. not full-screen. To do this I have an OnRecordLoad script trigger, to run a script called 'Film control'. My container field has an object name of 'Media'. Given this I have a very simple script step of, 'AVPlayer Play [ Object Name: "Media" ; Presentation: Start Embedded ; Position: 13]'

       

      However, the Position value is ignored and the film starts at the beginning. The only time it works is if I select the filed name, rather than the object, but then it opens in full-screen, which I don't want.

       

      Adding an 'AVPlayer Set Options' step after the Play script step does nothing, other then restart playback from the beginning again. I have even tried adding a short pause between Play and Options but that doesn't help.

       

      Is this a bug or am I missing something blindingly obvious?!

        • 1. Re: AVPlayer ignoring start position except when allowed to start in full-screen
          TSGal

          reggleton:

           

          Thank you for your post.

           

          I am unable to replicate the issue.  This is what I have done:

           

          1. In FileMaker Pro 15.0.2, I created a Container field "Container".

          2. In Layout Mode, I set the field for Interactive content.

          3. I gave the Container field the object name "Media".

          4. In Browse Mode, I inserted a mp4 video file (1:41 in length).

          5. In Script Workspace, I created a script "TEST" that executes the step:

              AVPlayer Play [ Object Name: "Media" ; Presentation: Start Embedded ; Position: 13 ]

          6. I set the file for Network Sharing.

          7. I launched FileMaker Go 15 from an iPad.

          8. I opened the hosted file.

          9. I tapped the left arrow, tapped Scripts, and tapped "TEST".

           

          The video started playing embedded in the Container field starting at the 0:13 mark.

           

          Let me know what I am doing differently than you so I can reproduce the issue.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: AVPlayer ignoring start position except when allowed to start in full-screen
            reggleton

            Many thanks, TSGal. This matches what I had. However, I had inadvertently ticked the 'Start playback automatically' option for the container field. Clearly this must override any AVPlayer commands.