13 Replies Latest reply on Jan 13, 2017 7:32 AM by bradleyboggs

    Scheduled Export Not Working Correctly - FM Server 15

    bradleyboggs

      Hi All,

       

      I've been racking my brain and googling myself stupid over the issue but haven't been able to resolve it.

       

      Recently I moved our company's solution from Server 12 on an old box to Server 15 on a new box.

       

      On the old box in Server 12, I had a scheduled CSV export run 3 times a day (inventory data), then had Server 12 run a batch script to upload it to an FTP.

       

      In trying to setup the same functionality on the Server 15 machine, first I was encountering an error. Ran it as PSOS from the client and got this: " "inventory.csv could not be created on this disk. Use a different name, make more room on the disk, unlock it or use a different disk." Confirmed this after the fact by checking the log and seeing error 800 in the server Activity.

       

      After some research I learned that FM Server can only export to its own folders for security reasons. Fine. Changed the file path to a variable $path, value: "filewin:" & Get (DocumentsPath) & "inventory.csv" as suggested by FM Documentation here.

       

      Now, when I run this as PSOS from the client, or manually run the schedule, it says "OK" and doesn't throw any errors. But the .csv file is not in the folder. Tried searching the whole drive for it, no luck. Searched the other volume where the database file itself is and still no luck. Turned on hidden files in the FM server documents folder, no luck. Hard-coded the filepath into the $path variable ("filewin:/C:/Program Files/FileMaker/Filemaker Server/Data/Documents/inventory.csv". When the script runs with this path, it shows "OK" but I still can't find the file anywhere on the server. (To get this patch and make sure it was totally correct, I ran a PSOS script to email me from the server with the $path variable in the body of the email).

       

      If I change the path to desktop and run it in the client, it saves to my desktop as it should.

       

      Our Setup: FM Server 15.0.2.206 running on Windows Server 2012 R2. 16gb RAM. OS/Server software on system SSD, Main database file stored on Raid 5 volume made up of 3 SSD's. Server-Side Plugins are enabled, and the only one currently installed is 360works' Email.

       

      Thank you in advance for any help you can provide!

       

      -Bradley