IanJempson

FileMaker Advanced won't launch after applying 15.03 updater

Discussion created by IanJempson on Jan 24, 2017
Latest reply on May 9, 2017 by TSGal

I ran the Check for Updates command in my copy of FileMaker Advanced 15.02, downloaded and ran the installer and it now won't launch. It appears that Info.plist is now invalid after the update.

 

Mac OS X Yosemite 10.10.5

Mid 2015 15 inch MacBook Pro Retina

16GB Memory

 

I tried rebooting the computer but still no luck. Clicking on the icon in the dock has it bouncing once then nothing.

In my console I see the following log entry.

24/01/2017 11:56:26.744 Finder[864]: There was an error parsing the Info.plist for the bundle at URL Contents/Info.plist -- file:///Applications/FileMaker%20Pro%2015%20Advanced/FileMaker%20Pro%20Advanced.app/

The data couldn’t be read because it isn’t in the correct format.

<CFBasicHash 0x61800066fac0 [0x7fff779a9ed0]>{type = immutable dict, count = 2,

entries =>

  0 : <CFString 0x7fff77974660 [0x7fff779a9ed0]>{contents = "NSDebugDescription"} = <CFString 0x6180006791c0 [0x7fff779a9ed0]>{contents = "Unexpected character b at line 1"}

  1 : <CFString 0x7fff779816c0 [0x7fff779a9ed0]>{contents = "kCFPropertyListOldStyleParsingError"} = Error Domain=NSCocoaErrorDomain Code=3840 "The data couldn’t be read because it isn’t in the correct format." (Conversion of string failed.) UserInfo=0x6180002751c0 {NSDebugDescription=Conversion of string failed.}

}

 

I can't open the plist in Xcode - it complains about the format.

Outcomes