AnsweredAssumed Answered

Using Data Separation Model and am having Deployment Issues

Question asked by cplinta@accelse.com on Jan 25, 2017
Latest reply on Feb 3, 2017 by cplinta@accelse.com

I have FM Pro 15 Advanced installed locally.

I started to develop an app in a single database file.

At some point i decided to adopt the data separation model.

I now have two databases, one containing data (DATA),

the other contains the layouts, scripts and such (CODE).

 

My development process entails making changes to CODE locally,

and then pushing those changes out to the server running FM Server 15

by doing a file level copy/paste, replacing the remote CODE database file

with my local CODE database file.

I also have FM Pro 15 Advanced installed on that server.

 

After splitting out the data into the DATA database file, i have added new

fields to existing tables with no issues.  I've made a point to

add the fields locally to DATA and to the remote (live) DATA database

at the same time to avoid any issues.

 

Here is the problem I'm now seeing...

I added a new table to both databases (the table is named Logs).

I made code changes to my local CODE database (a new script and layout).

and when i pushed those changes out to the server, by coping and pasting the

CODE database file, the new layout and script had the fields either changed

to different fields in the same table or field refs were marked as missing.

 

Thinking i created something out of order, I deleted the Log tables in

both DATA databases and re-created them from scratch to ensure all

fields were created the same and in the same order.

I am seeing different but similar results.

 

I then decided to delete the Log table from the DATA database being served.

I copied my local DATA database to the server desktop.

i opened this dev DATA database on the server and "copied" the Log table (Manage->Database->Tables->Copy).

i opened the production DATA  database on the remote server and pasted the table into it (Manage->Database->Tables->Paste).

Now, When i opened the CODE database on the server, all fields that referenced

the Log table on the new layout and script show as missing.

I also tried "Import" and see the same result (Manage->Database->Tables->Import)

 

In the CODE database on the remote server, i did this

    File->Manage->Database

    Relationship tab

    and when i clicked on the Logs table reference, it had NO table selected.

    Once i selected the Logs table, all was well, the new script and layout now have

        the fields properly mapped/defined

   

But, this is unacceptable because i dont want to have to remember to

take this step every time i push out code changes...

It also has me leery of adding new tables going forward.

 

Its been years since i used Filemaker... I picked up a project recently to use it again,

so im not up to date on the current approaches/tools to use.

 

Thanks in advance for your help.

 

Chuck

Outcomes