4 Replies Latest reply on Jan 30, 2017 3:17 AM by barbarat

    Special characters (accent marks, European letters) not exporting correctly to XML

    barbarat

      Hi- My knowledge of FMP is very basic, so please excuse my ignorance!

       

      I am working on an iMac OSX 10.9.5 and FMP 12.0v5 on a database set up by someone we are really not in contact with much anymore. We input data direct into FMP, not imported from anywhere or copy and pasted from Word, etc. From this we get EAD, which we then export as XML and send to another institution who uploads it to their website. To do to this I use a script that was created, save as Tab separated text with a .xml extension added and remove the .tab once it’s been saved.

       

      I have been having problems with some special characters not converting to XML - sometimes the character is missing, sometimes the whole letter, here's an example where the letters are missing.

       

      W rolach głόwnych: Jean Servais, Carl Mohner, Robert Hossein, Claude Sylvain / Film produkcji francuskiej: Produkcja: Indusfilm - Prima Film S.N. Pathe Cinema / Režyseria / Jules / Dassin / Rififi

      Designer: Hübner

       

      becomes

       

      <p>W rolach g  wnych: Jean Servais, Carl Mohner, Robert Hossein, Claude Sylvain / Film produkcji francuskiej: Produkcja: Indusfilm - Prima Film S.N. Pathe Cinema / Re yseria / Jules / Dassin / Rififi</p><p>Designer: H&uuml;bner </p>

       

       

      I noticed in Preferences under Fonts, Font Locking was ticked. I unticked,shut down FMP, and opened it again. The problem remained. I have tried changing my keyboard to Polish and also the character viewer to try to get the letters. I have also tried  File>Export as XML saving both as .xml and .tab and that keeps the characters, but it is not EAD.

       

      I have tried looking in the script, but I am not sure what I am looking for- I made a duplicate to poke at- and after much searching I am here hoping someone can help me!

       

      Thanks in advance!