1 2 Previous Next 16 Replies Latest reply on Feb 3, 2017 2:07 AM by Johan Hedman

    WebDirect giving error startpage

    Johan Hedman

      I got this strange window when I tried to open up WebDirect

       

      Skärmavbild 2017-02-01 kl. 20.12.23.png

       

      I have worked on this solution the whole day, but logged out a few hours for dinner and when I got back it looked like this when I did the url to go directly to the file

      http://doman.com/fmi/webd#FIleName

       

      When I look at the FMSAC for errors, only things I can see that is error is

       

      Skärmavbild 2017-02-01 kl. 20.13.41.png

       

      Strange things is that was not connected with WebDirect at either 20:07 or 20:01 . I logged out at around 18:30.

       

      Any clues why I get the strange error start page?

       

      The solution seems to work great after I have logged in.

       

      FileMaker Server 15v3

      Windows Server 2012 SP2

        • 1. Re: WebDirect giving error startpage
          ClickWorks

          It seems like the browser fails to load part of the HTML and certainly the CSS instructions. Most likely there is an issue with the webserver (IIS). Have you tried to restart IIS using the IIS Manager yet? Are there any other kind of websites or webserver running on top of IIS?

          • 2. Re: WebDirect giving error startpage
            Johan Hedman

            I have restarted the service for IIS and that did not make any difference. Also restarted the whole machine. Did not make any difference that either

            • 3. Re: WebDirect giving error startpage
              CamelCase_data

              I've also had seen this on my development server, with the same OS & FMS configuration. Didn't take the time to check any details when it happened, but I will try if it does again.

               

              johanhedman - what browser were you using? Safari I guess? I was, in any case.

              • 4. Re: WebDirect giving error startpage
                Johan Hedman

                I am using Safari 10.0.3 on my Mac 10.11.6

                • 5. Re: WebDirect giving error startpage
                  ClickWorks

                  johanhedman have you tried a different browser? Have you tried connecting to the server using a different hostname, or the IP address? Have you tried to log in to the machine and use 'localhost' as a hostname?

                   

                  One thing you can tweak is enable/disable static content compression. In the IIS Management console, select the website, click 'Compression' and check or uncheck the 'enable static content compression'. Be sure to restart IIS after each change.

                  • 6. Re: WebDirect giving error startpage
                    Johan Hedman

                    Skärmavbild 2017-02-02 kl. 10.43.12.png

                    No error if I runt the same url Chrome 58.0.2999.4

                    • 7. Re: WebDirect giving error startpage
                      Johan Hedman

                      I have tried the compression trick and restart after without luck.

                       

                      Got very strict security on that machine, so no way to enable javascript to run IE on that machine with Localhost. Thanks for the suggestions

                      • 8. Re: WebDirect giving error startpage
                        TSGal

                        Johan Hedman:

                         

                        Thank you for your posts.

                         

                        I have been discussing this forum thread with another Support Technician (TSPigeon), and we don't have an immediate answer.

                         

                        TSPigeon tried disabling Java, but received a different error message.

                         

                        Since this used to work, obviously something has changed.  We thought it might be a damaged IIS configuration, but since WebDirect works with Chrome, this is probably not the cause.

                         

                        Since Safari preferences are stored for each Mac user account, create a new Mac user account, login to the new user account, launch Safari and access the file via WebDirect.  Do you still get the same message?  If not, then return to your original user account, and remove the preferences file:

                        [User Account] -> Library -> Preferences -> com.apple.safari.plist

                         

                        If you still get the same error message, go to another machine (if available, and possibly with a different version of Mac OS), launch Safari, and try accessing the file.  Does this work?

                         

                        Is this issue occurring for all files or just a particular file?  That is, if you try accessing the FMServer_Sample file, do you also get the same message?

                         

                        Other options to check are to make sure anti-virus/security software is disabled.  Also, if you have any backup software, make sure you are not backing up the folders where the databases reside.

                         

                        Keep me updated with any progress.

                         

                        TSGal

                        FileMaker, Inc.

                        • 9. Re: WebDirect giving error startpage
                          Johan Hedman

                          On the same machine, logged on as another users (account) I do not get the same error using Safari.

                           

                          I do not even have a file called com.apple.safari.plist on my computer. I got many other files that starts with com.apple. but noone that ends with safari.plist.

                           

                          At the moment I one have one file open for WebDirect, the FMServer_Sample have been deleted from FMS.

                           

                          There is not Anti-virus running on the machine. No index search. It is a dedicated server. No backup software that runs on live data.

                           

                          The problem is only occurring when I am trying to log in to WebDirect with my main account at my Mac using Safari. It works without any errors and all other machines (Mac/Windows) that I have tried.

                          • 10. Re: WebDirect giving error startpage
                            jerrysalem

                            I have this same issue.

                            When I log into WebDirect from a Mac, I get the error messages.

                            On a PC everything looks ok.

                             

                            I think the problem went away briefly when I cleared my browser cache.  But then came back.

                            For this solution, all the users are PC's and they open the files directly (without going to the landing page with the error), so for me this isn't an issue.  But I do see the error messages.

                             

                            Jerry

                            • 11. Re: WebDirect giving error startpage
                              TSGal

                              Johan Hedman:

                               

                              The two Macs that I currently have access are macOS Sierra 10.12.3 and Mac OS X 10.10.5, and both have a com.apple.Safari.plist file.  I'm looking for a Mac OS X 10.11.6 machine to verify.

                               

                              Sort your Preferences file by Date Modified descending.  This should show any file related to Safari for today.

                               

                              You may want to also try the suggestion by "jerrysalem".

                               

                              TSGal

                              FileMaker, Inc.

                              • 12. Re: WebDirect giving error startpage
                                Johan Hedman

                                Skärmavbild 2017-02-02 kl. 18.25.34.png

                                This is the list of files at [User Account] -> Library -> Preferences -> sorted

                                • 13. Re: WebDirect giving error startpage
                                  cji_paygo

                                  We have a FileMaker Cloud-based product offering and we've seen this error on all platforms and on safari and chrome.

                                   

                                  Clearing the browser cache fixes the issue each time.

                                   

                                  We've found that when this error occurs, our solution begins to have performance issues, specifically, script triggers seem to stop working.

                                   

                                  We haven't yet been able to figure out why this happens, but clearing the cache has always fixed it.

                                   

                                  Btw... Hi jerrysalem!! !! Nice to see you here.

                                   

                                  -Chris

                                  1 of 1 people found this helpful
                                  • 14. Re: WebDirect giving error startpage
                                    Johan Hedman

                                    This worked for me too. I do not have any script triggers at my main layout, but I get the error already when I click on the File from Starter Screen

                                    1 2 Previous Next