AnsweredAssumed Answered

Filemaker Go 14 & 15 drops 1st digit of scanned barcode. (BT Scanner)

Question asked by eoin on Feb 6, 2017
Latest reply on Jun 12, 2017 by eoin

Product and version Filemaker Go 14.0.4 & Filemaker Go 15.0.3

OS and version      iOS 8.2 & iOS 10.2.1

Browser and version N/A

Hardware iPad 2, iPad 3, iPad Air, iPad Air 2, iPad Pro

Bluetooth Scanner Motorola / Symbol CS3070

Description:

Database hosted on local network FMS15 server (Mac), Mixture of FMP15 Macs and 14 iPads on the local network.

 

On the iPad ....

User taps into an empty portal row on a layout designed to receive scanned Barcodes from a bluetooth scanner. A scan is made and the scanner transmits the data and populates the the field with the scanned data. A carriage return appended to the barcode forces the "on object validate" script trigger to run a script which checks for the existence of the barcode in the stock control file and populates fields in the portal row the scan data has been entered on. Providing the barcode existed the script then moves focus to the next empty row of the portal and selects the scandata field ready for the next scan.

 

This logic has performed flawlessly for the past number of years up to and including Filemaker Go 13.0.9

 

When we upgraded Filemaker Go from 13.0.9 to 15.0.3 we noticed that on 50% of the scanned barcode data the first digit of the barcode was missing in the scandata field. This naturally caused an error because it didn't match the stored barcode in the stock control file.

 

We tried several of the BT barcode scanners and they all returned the same result. Filemaker Go dropping the 1st digit on 50% of the scans when populating the scandata field.

We tested the Scanners  with the notepad on the iOS devices and the Notepad accepted 100% accurate scans from the scanners with all digits present.

 

Filemaker Go 14.0.4 displays the exact same problem dropping the 1st digit of the barcode when it populates the scandata field.

 

 

 

 

Workaround Re-Installed Filemaker Go 13.0.9 on the iPad and everything works as it has for the past 3 years.

But the problem will be inconsistency with layout design for elements introduced in FM14 & 15 don't render in FMGO13.

FMGo13 is now 2 generations behind, so not a longterm solution.

Outcomes