AnsweredAssumed Answered

File Access Problems when syncing on iOs

Question asked by IT_User on Feb 9, 2017
Latest reply on Feb 10, 2017 by IT_User

Avoid FMGo Connection Interrupted

Server Timeout Disconnect

 

In the attached links, it goes back to questions that I had that dealt with a file on an iOs device, making sure it stays live and up to date.

 

So what I have done is worked on a local file that syncs to the one on the server.

That seemingly works, however there is a problem that just recently came up when I was testing. When the local file tries to reach the file on the server, it doesn't always connect.

In talking with others there is two consensus of what might be the cause:

  • The Wireless access point is blocking access
  • File security permissions are not working (File Access tab in Security)
    • "Reset All" temporarily works (on the server file)
    • Deauthorizing and Authorizing sometimes works (on the server file)
    • Turning off the File Access requirement doesn't seem to help (on the server file)

I do have File Access on the local file, but I haven't tried turning that off.

Since I can't debug exactly what is going on, on the iPad this makes it harder. (I have put in some custom dialogs to see some things.)

The local file with the syncing to the server file works on my desktop, but that is a wired connection. (I could try the same wireless connection.)

 

It could be that I'm making a duplicate of the local file and putting that on the iPad, which makes the file not work.

(I put on the duplicate file on the iPad newly each time for testing, because I need a file without certain info on it, which will be filled later [dealing with Get(PersistentID)].)

 

Is there something I'm not thinking of?

 

To my knowledge, it had been working until recently.

I'll try a few more things, but hopefully get answers in the meantime.

Thank you

Outcomes