AnsweredAssumed Answered

Login problem - with just one database on a server

Question asked by gtorborg77 on Mar 1, 2017
Latest reply on Mar 3, 2017 by gtorborg77

I (along with a customer of mine) is having a problem.  I work in the IT department of a major university.  I have a customer with whom I've worked fairly often.  We have a FileMaker 12 Server that is shared by about 60 people in 9 different departments.  We also all use a virtualized version of FileMaker Pro 12 using Citrix Receiver.  We all use and enjoy the software with hardly any problems, ever.  This one is a strange exception.

 

The customer in question (her name is Pam) has two databases on the server.  One is visible to her, the other is not.  It's that simple.  Both have 100% identical security setups that look like this:

It just so happens that every one of the databases on the server, in addition to the accounts for each of the people in the department, includes the accounts you see here as "gtorborg" and "filemakeradmin".  The former is there so that I can make changes to the security, if needed.  The latter is an externally authenticated account.  In every database on the server, this allows me to open any database for support purposes - except for one.  The customer's two databases (let's call them A.fmp12 and B.fmp12) are set up with the exact same security, even down to authentication order.  The passwords are identical in the two files.

 

But: I can see both databases when I go to Open Remote, but can only open A.fmp12, not B.fmp12.  The customers can't even see B though they can see A.  When I try to open B, I get prompted to log in to the database, which should not happen.  That is, the externally authenticated account should get me right in without prompting me, just as is the case with A and with every other database on the server.  I can open a local copy of B that is saved elsewhere (a launching point I use for putting databases on the server) using my gtorborg account, but when I try to open B on the server by open remote, I get prompted for a FIlemaker-authenticated account and password.  When I enter gtorborg and my password, I get this error:

 

 

I can't use anyone else's account name and password, either.  I have tried this both with and without having another database open using the filemakeradmin account.  No difference.  I have moved up the authentication of the filemakeradmin account to the top so it is done first.  No difference.  I have tried changing a security setting on the Server to list all databases (see illustration below, I've since changed it back), but this doesn't help.

 

Do any of you have any ideas about this?  Thanks in advance.

Outcomes