6 Replies Latest reply on Mar 3, 2017 6:01 PM by philmodjunk

    Why does button command 'go to related record' fail?

    sillybird

      Am in FMP 13 and trying to get a button on one layout to return the single record in a related layout, but nothing happens after hand cursor and button behavior (flashes white).  Have tried defining the (text) field itself as the button but get a similar result.  Do I need to check the 'show in a new window' option, if I am already specifying an existing layout to use for display?

       

      I have tried creating a button and defining it, then grouping it with the field that displays the text to match in the related record.  Is that normally enough to 'point out' the context from which I am looking for a related record?

      If I can get that 'grouped object button' to behave, how could I later enter or modify data in that field display?

       

      In the attached screenshot of the relationship graph, am trying to make 4 separately scripted buttons in the left table's layout, 'attached' to one of the four 'referenceNAME i through referenceNAME iv' displays, to call up related records via relationship to reference_name in the right table.  I am also attaching a shot of the revealed relationship when I click the "=" between the two tables.

       

      Thanks in advance!