AnsweredAssumed Answered

Afficher des résultats dans 2 modèles différents

Question asked by evolu4 on Mar 6, 2017
Latest reply on Mar 6, 2017 by siplus

Bonjour

Mon anglais n'est pas suffisant pour poser cette question dans la langue de Shakespeare.

Voilà mon problème. J'utilise une BD sous FM12 pour gérer les résultats des régates de mini voiliers.

Je m'explique :

Dans le 1er modèle je saisis 2 informations la note de présentation des juges et le temps en seconde que chaque concurrent à mis pour faire chaque régate. Nous faisons en général 3 régates.

Dans ce même modèle s'affiche le temps pondéré. Ce temps est calculé en fonction d'un coefficient variant d'un voilier à l'autre pour tenir compte des différences de poids et de surface de voile.  La formule est  "Arrondi( Tps_Regate1 * R;2)". Ce temps pondéré donne un nombre de points à chaque concurrent pour chaque régate.

Le calcul est le suivant :

le concurrent qui fait le temps mini obtient 100 points les suivants obtiennent un nombre de points au prorata du temps qu'ils ont mis. la formule est la suivante "Arrondi((Min_Tps_Pondere_Regate1 /Tps_Pondere_Regate1)*100;2)"

Pour le résultat final, on calcule la moyenne des 2 meilleures manches par régate avec la formule suivante : Arrondi((Somme_Point_Regate-Min_Point_Regate)/2;2). A cette note on additionne les points de présentation pour avoir le total final.

Jusque là, sur ce modèle tout fonctionne correctement.

 

Pour faire le classement, j'utilise un 2ème modèle dans lequel je n'affiche que la note de présentation, les points des régates et le total final. Je fais un tri décroissant sur le total final puis sur la manche non retenue dans le calcul de la moyenne et en dernier critère la note de présentation. Tout ça pour éviter les ex æquo. Mais voila lorsque j'affiche ce 2ème modèle via un script les points ne sont pas affichés. La rubrique affiche 0

 

Après plusieurs semaines à chercher l'erreur ou le problème, je ne trouve pas de solution, ni là où j'aurai pu faire une erreur ou un oubli.

Pour vérifier le problème si j'utilise l'affichage des données via le "Visualiseur de données" et en exécutant le script "Classement" en mode pas-à-pas les résultats s'affichent correctement.

 

je mets en pj ma base de test.

 

merci pour toute l'aide que vous apporterez.

 

Cordialement

Outcomes