4 Replies Latest reply on Mar 23, 2017 7:07 AM by TSGal

    WebDirect does not respect "allow vertical scrolling" portal option.

    robertnaud

      Product and version : FileMaker Server 15.0.1.137

      OS and version: Windows Server 2012 R2 version 6.3 build 9600 (for FileMaker Server)

      Browser and version : Chrome 57.0.2987.110

      Hardware: lenovo ideapad miix 510-12ISKL (running Windows 10 Pro version 1607 build 14393.693)

      Description: On windows OS WITH A TOUCHSCREEN, showing a portals set to show only 4 rows (first portal shows record 1 to 4, second portal shows record 5 to 8) where "allow vertical scrolling" has been removed for each, web direct interprets finger movement on the screen as a gesture that allows the user to scroll up and down on both portals (by design we want to prevent this from being possible). Using a mouse with the same computer and using the mouse wheel to scroll has no effect as expected.

      How to replicate: on a layout having portals showing records via the same relationship side by side, set your portals to show records starting at record 1 on the first record and starting at record 5 on the second one. On both portals, remove the checkbox for "allow vertical scrolling". Launch a web direct session where you see the portals on a windows device with a touchscreen and swipe on top of the portals. The postals scrolls when they are not supposed to. This behavior could not be replicated on an iOS device, but the screen was too small on those devices (could conflict with scrolling within the page itself)

      Workaround: none