kupietz

Restarting Mac kills WebDirect until FileMaker Server 15 is reinstalled

Discussion created by kupietz on Mar 22, 2017
Latest reply on Oct 3, 2017 by user27352

I installed FileMaker Server 15.0.3 on my MacBook Pro running the latest MacOS Sierra to grab a few screenshots of a solution running in WebDirect. Everything worked fine until I restarted my MacBook, after which every time I tried to use WebDirect my browser (Opera) said the server wasn't responding. The FileMaker Server technology test of WebDirect gave the same result. The Web Server section in the admin console had no checkmark next to it and no "on/off" switch to allow me to restart it. When attempting to re-deploy, I got a message "Test web server (http://192.168.12.22:80/fmi-test/test.xml): Connection refused (Connection refused)" on the "test" step. The IP address is correct for my machine Changing the test IP address to 127.0.0.1 gave the same result.


So I uninstalled FileMaker Server completely and reinstalled, which fixed everything, and WebDirect worked fine again. Just to test, I restarted again, after which WebDirect was dead again, with the same symptoms. Stopping and restarting the FileMaker Server didn't help again, either.

 

Trying

sudo /Library/FileMaker\ Server/HTTPServer/bin/httpdctl start

or

sudo /Library/FileMaker\ Server/HTTPServer/bin/httpdctl restart

from Terminal gave an Exit Code 1 and didn't fix the problem.

 

I have no other web services running on my machine that I'm aware of, and a search for "http" in my Activity Monitor revealed no processes containing that string in the name.

 

It's a stock install of Sierra, only about a month old, updated with all available updates.

 

Seems like WebDirect can't survive a restart without requiring a from-scratch reinstall of the entire software package.

Outcomes