6 Replies Latest reply on May 3, 2017 12:59 PM by davidempson

    Some OS X keyboard shortcuts stopped working

    justinc

      I'm running OS X 10.11.6.

       

      This isn't completely specific to FileMaker - it's more of an OS X user-account issue; but I figured some folks here might be able to lend a hand since this seems to be functionality that is very often used in FileMaker.  And support from the Apple forums is not useful so far.

       

      I have just recently run into a problem with a number of keybindings that have stopped working in some applications.

      Option-Right Arrow = advance to next word

      Option-Left Arrow = go back to previous word

      Option-7 = pillcrow

      Option-return = insert line feed in calculation box

      Option-tab = insert tab in a calculation box

       

      I use these shortcuts all the time, and so I am constantly missing them.  This issue started for me about 2 days ago.  It appears to have happened in the middle of the day - I was working all day and don't recall seeing the issue until late in the afternoon.

       

      The problem only appears to be in certain applications:

      OK:   Slack, Thunderbird, Terminal (Terminal has it's own special key-binding, though.)

      Not working:  Mail (Apple), Firefox, TextEdit and FileMaker are all non-functional in this regard.

       

      Cmd-Right Arrow (move to end of line) and Cmd-Left Arrow (move to start of line) work correctly in all these apps.

       

      Option-Delete (delete one word) doesn't work.  Option-Backspace (backspace one word) does work.

       

      I have rebooted my system (no difference).  I did not perform any system updates.  I do have cats, and they love to step on the keyboard... 

       

      I tested out the Guest account on this laptop and it DOES work correctly there - I have no troubles with 'option-...' keyboard shortcuts in FileMaker or any other applications.  So it would seem to be user specific, something in my system settings.  But then these shortcuts work fine in some applications on my user.

       

      I tried removing the few applications that I have running at login for my user, but that didn't help.

       

      Anyone have any ideas?

        • 1. Re: Some OS X keyboard shortcuts stopped working
          justinc

          Bump.

           

          Nobody else has run into this, huh?

          • 2. Re: Some OS X keyboard shortcuts stopped working
            justinc

            I got it figured out and solved - thanks to a guy at an Apple store (Genius Bar).  I took my laptop in the other day just on the off chance that they might know what was going on; he did a bit of research and asking of co-workers and finally came up with a solution:  a extra 'Input Source' under "Keyboards" in System Preferences.

             

            I had two input sources (for some reason) - one was "US" and the other was "Unicode hex input" or some such.  It appears that certain applications were using "US" (these are the applications that worked) and others were defaulting to "Unicode Hex input" (these are the applications that didn't work).  The Unicode input source apparently didn't have a key binding mapped for these various key combinations that were failing (there were many - but not all).

             

            So I removed that 2nd input source, leaving just the "US" one, and everything was working again!  I'm so happy! 

             

            Justin

            1 of 1 people found this helpful
            • 3. Re: Some OS X keyboard shortcuts stopped working
              ilirtopalli

              Unfortunately I DO use other input methods (turkish, Russian, Ukrainian) along with US English keyboard and I DO switch keyboards occasionally.  This "fix" essentially breaks this OS function and prevents me from using international keyboard sets.  It limits me to US only.  For me this is not "solved" although I thank "justinc" for his answer.

              • 4. Re: Some OS X keyboard shortcuts stopped working
                ilirtopalli

                actually, even after removing my input sources option-return still does NOT function in Filemaker 15 while it DOES function in filmmaker 13.  This indicates the problem is filmmaker and NOT the OS.

                • 5. Re: Some OS X keyboard shortcuts stopped working
                  justinc

                  So you only have 1 input source left in the Keyboards setting panel?  What keyboard do you have defined?  Mine is listed as simply "U.S.".

                   

                  It's odd that it would work in some apps and not in others, then.  Do you have any custom keybindings set up for these apps?  Perhaps that is why it works in one and not the other.  It also seems like you would be able to set up custom keybindings for FM15 specifically, so that the other keyboards would also act that way.  But I'm not certain.

                  • 6. Re: Some OS X keyboard shortcuts stopped working
                    davidempson

                    In case someone actually wanted to retain access to the Unicode Hex Input keyboard, some further explanation may be helpful. This also applies to most non-Latin language keyboards.

                     

                    If you have multiple input sources enabled (via System Preferences > Keyboard > Input Sources in macOS 10.12 Sierra, it moved around a bit in earlier versions), OS X lets you switch between them with the Input menu (if that is enabled), or with a keyboard shortcut, which is usually either Control-Space or Command-Space. (See System Preferences > Keyboard > Shortcuts > Keyboard.)

                     

                    What probably happened in this case is that justinc had accidentally switched input source to Unicode Hex Input by bumping the keyboard shortcut. I prefer Control-Space to switch input source, with Command-Space for Spotlight, because it is harder to bump Control-Space by accident.

                     

                    For most OS X versions, the input sources which can be selected depend on the capabilities of the active application. If the application supports Unicode text entry, any input source can be selected. If the application only supports 8-bit text, then you have a limited selection of input sources, excluding the ones which require Unicode (such as Unicode Hex Input). If your chosen input source requires Unicode, and you switch to an application which doesn't support Unicode, then OS X temporarily switches back to the US keyboard while that application is active, then restores your chosen input source when you switch to an application which supports Unicode.

                     

                    This explains the behaviour justinc saw which changed depending on the application: the chosen Unicode Hex Input keyboard was only available in the applications which support Unicode input, including recent versions of FileMaker.

                     

                    You could have left Unicode Hex Input available in the Input menu, and simply switched back to the US keyboard via the Input menu, or the keyboard shortcut.

                     

                    It looks like macOS Sierra (10.12) has changed things slightly: it is possible to select Unicode Hex Input or other input sources which require Unicode in applications that don't support Unicode, but you can only type characters which exist in the character set used by the application. The OS appears to fall back to the US keyboard in some cases (e.g. Arabic) without changing the keyboard shown in the Input menu.

                     

                    For reference... with the Unicode Hex Input keyboard, the Option key is reserved for entering Unicode character codes: hold down Option while typing a four digit hex number, and the corresponding Unicode character is typed. For example, Option-004E gives U+004E which is 'N', and Option-221A gives U+221A which is a square root symbol '√'.

                     

                    You can find Unicode character codes via the Character Viewer (Emoji and Symbol viewer in recent OS versions).