8 Replies Latest reply on Apr 5, 2017 12:30 PM by halaeliya

    Disable keyboard's "Continue"

    halaeliya

      Hello,

       

      Is there a way to disable the "Continue" that shows in the top-right corner of the keyboard? We don't want the user to proceed to the next page unless they complete some fields in the current window, we do have a continue button that will show once the fields are completed but the user can still click the keyboard's continue and proceed to next screen without filling out all the required fields.

       

      unnamed.jpg

        • 1. Re: Disable keyboard's "Continue"
          Jason Wood

          You currently have a Pause and then a Go to layout (or similar). Try replacing with this:

           

          Loop

          Pause Script

          Exit Loop If [conditions]

          Show Dialog ["Please complete required fields first"]

          End Loop

          Go to layout [page 2]

          • 2. Re: Disable keyboard's "Continue"
            Jaymo

            Must be an old version of FileMaker Go. The script Continue button doesn't show in the keyboard on FileMaker Go 15. Anyhow, I would put in an Exit Loop If statement wrapped in a loop to prevent the Continue button from preceding. The condition in the Exit Loop If to exit the loop will be those field(s) being filled. If the user clicks continue then the script will just loop again. Also, place the Allow User Abort [Off] step at the beginning so the Cancel button disappears.

             

            You could also consider separating the two parts of the script so the Continue button never shows. One script dumps them on the layout in your screen shot and then next one moves on when they are done. You will still need an If statement to determine if the fields are field but no looping construct.

             

            In addition, you can hide the Continue and Cancel button using the Show/Hide Toolbars script in an script that performs on open.

            • 3. Re: Disable keyboard's "Continue"
              halaeliya

              Jaymo, this continue on the keyboard shows by default not by script. I meant we have another continue button that is programmed to show after all fields are completed. But the users are clicking the built in continue and are able to proceed without all the required fields. So we were looking for a way to disable this built in "Continue"

              • 4. Re: Disable keyboard's "Continue"
                halaeliya

                Will this apply to the Built in Continue in the keyboard?

                • 5. Re: Disable keyboard's "Continue"
                  Jaymo

                  I'm not familiar with all the versions of FileMaker Go but I'm pretty sure you have a script paused.

                  • 6. Re: Disable keyboard's "Continue"
                    Jason Wood

                    It won't remove it but it will render it non-functional if the user hasn't met your conditions for continuing.

                     

                    There's some confusion between you and Jaymo because you said "this continue on the keyboard shows by default not by script", and Jaymo is taking that to mean that you do not have a script paused. But you do have a script paused and that's why you have the continue button. The "continue" button on your layout, which you are hiding if conditions are not met, is also a "resume script" button. Right??

                    • 7. Re: Disable keyboard's "Continue"
                      philmodjunk

                      An alternative approach is to break up your script that pauses into smaller pieces and remove the Pause step.

                       

                      Each "continue" button just performs the needed next piece of the original script. Then there is no paused state to put this button into your keyboard.

                      • 8. Re: Disable keyboard's "Continue"
                        halaeliya

                        Thank you everyone!