7 Replies Latest reply on Apr 12, 2017 6:33 AM by TSGal

    Portal background not working on web browser

    LarsHed

      I just created a portal on a layout (with a background photo) that is used on iOS with FM go app as well as the web with Safari/Chrome. The portal is visible only when it has records to show and it should be transparent (only show the text in the records). This works fine with the "hide" calculation and "no background" (full transparency)  on MacOS Sierra FM client and iOS 10.2 via WebDirect FM go client. But not on the normal web with Safari or Chrome. Instead the portal is always there on the web, empty with a solid white background. Why? The only explanation I can see is that portals don't support transparency on all platforms. Or...?

       

      I temporarily added "don't show portal at all" on the web [Get(systemplatform)=4] but it's not a great solution.

        • 1. Re: Portal background not working on web browser
          TSGal

          LarsHed:

           

          Thank you for your post.

           

          I am unable to replicate the issue.  This is what I have done:

           

          1. Using FileMaker Pro Advanced 15.0.3 under macOS Sierra 10.12.4, I created a database file with two related tables.  I entered one record for the main table and two related records in the secondary table.

           

          2. In the Body of the main table layout, I set the Fill to an Image.

           

          3. I created a Portal into the secondary table that displays phone numbers.  I set the Portal Row fill to none for transparency.  In Browse Mode, I verified the Background Image displays through the portal.

           

          4. I set the file for Network Sharing and WebDirect access, and uploaded the file to FileMaker Server 15.0.3.

           

          5. In Safari 10.1, I accessed the hosted file via WebDirect, and the Background Image displays through the portal.

           

          Please let me know what I am doing differently than you so I can reproduce the issue.

           

          TSGal

          FileMaker, Inc.

           

          Screen Shot 2017-04-10 at 9.30.28 AM.png

          • 2. Re: Portal background not working on web browser
            LarsHed

            Thanks for comment, TSGal.

            I've created a transparent portal on photo background before on another layout. I tried to copy that portal into the actual page. Still same result - the duplicated portal is showing a white background on WebDirect -Safari MacOS Sierra 10.12.3. but not in FM 15.03 and not in FM Go 14 or 15. The FMserver is however FMS 14 on Yosemite. I made screenshots from FM and from Safari below. I'm using merge fields in the portal since the user should not change the content. White text is of course invisible on the not wanted white bgd

            Skärmavbild 2017-04-10 kl. 18.58.52.png

            Skärmavbild 2017-04-10 kl. 18.59.25.png

            • 3. Re: Portal background not working on web browser
              TSGal

              LarsHed:

               

              Thank you for the additional information.

               

              Rather than using a copied and pasted portal, create a new portal and see if the issue still exists.  If so, then I will work with our Testing department to locate a Mac OS X 10.10 machine with FileMaker Server 14.0.4b installed.

               

              TSGal

              FileMaker, Inc.

              • 4. Re: Portal background not working on web browser
                LarsHed

                I have now tried to create a new portal and also tried with different themes. Still same result - Safari is showing a white background while FM 15 and FM Go shows transparency. I tried different custom themes and noticed some themes in FM15 seem unable to show transparent portals also in FM client - but didn't dig deeper in that.

                I get the impression that there is som kind of compatibility issue in between different FM versions.

                 

                (the sample TSGal shows above is exactly what I want - but can't create)

                • 5. Re: Portal background not working on web browser
                  CamelCase_data

                  LarsHed - are all the objects in the portal also transparent? In particular the text field?

                  • 6. Re: Portal background not working on web browser
                    LarsHed

                    Yes -  checked that record fields are set to transparency (none) and also the borders.  Also tried both merge fields and normal fields.

                    • 7. Re: Portal background not working on web browser
                      TSGal

                      LarsHed:

                       

                      Without seeing your file, it is difficult to determine if the layout is damaged, the file is damaged, or if there is a setting that has been overlooked.  Therefore, send in a clone of your file, and I will look over and test your file.  I have sent you a private message with instructions where to send the file.

                       

                      TSGal

                      FileMaker, Inc.