AnsweredAssumed Answered

FM iOS SDK 15.0.4 + Insert from URL • Issue

Question asked by blckfrm on Apr 11, 2017
Latest reply on Sep 14, 2017 by cmaning_1

Hi All,

 

I have an issue that I haven't encountered before where a standalone FM iOS SDK app uses Insert from URL do various tasks, sync (RESTfmSync) and send SMS's. The FM iOS SDK's I have used in the past have all had no issues.

 

I updated the app using to the latest version of the iOS SDK and I have encountered issues. The FileMaker file opens successfully.

 

The insert URL step appears to work, as the error 0 is returned (using a show custom dialog after the Insert from URL step), so it's not a missing field, or no record present, etc etc, the field being inserted to is on the layout and is a global field. After that step I show another custom dialog with the URL result, and it is blank.

 

I open the file in FMPA, run the same script using and again there is the same error 0 returned, however when I show the result of the insert from URL step it has the result.

 

I've looked at the Info.plist and I have the following items, image attached with all.

     - Allow arbitrary loads - boolean - yes

     - Allow Arbitrary Loads in Web Content - boolean - yes

     - Exception Domains   

          - web services I am using

 

I have also tried 8hrs of different combinations of Info.plist items but none of them are working consistently.

 

The script is used On First Window Open trigger.

 

In the config file I have the set to:

solutionCopyOption = once

 

 

I can only think that iOS or the iOS SDK is somehow blocking the Insert from URL step, or the web service it is calling.

 

Has anyone else had the same issue? If so, did you resolve it? How?

 

Versions:

XCode 8.3.1

iOS 10.3.1 (iPad)

FM iOS SDK 15.0.4

 

Please help.

 

Thanks,

Damien

 

(Tagging people who may know something)

nickorr

odubov

amallo

 

Message was edited by: Damien + Greg - Added attachments

Outcomes