AnsweredAssumed Answered

WebDirect Not Working FMS 15.0.3 Mac OS X 10.12.4

Question asked by taylorsharpe on Apr 17, 2017
Latest reply on Apr 17, 2017 by taylorsharpe

I have a client with a Mac OS X 10.12.4 Mac Mini, 16GB RAM, hundreds of gigs off available storage, and we're trying to get FMS 15.0.3 working on it.  I upgraded it from 14 to 15 and found out WebDirect was not working.  When you went to the WebDirect page that shows the files, it would show the files (plus the SSL warning since I haven't installed it yet), but the circle in the middle would keep going and never end.  There are only 2 files, the solution and the sample file.  While the circle is going, I can click on either file, but neither will open.  I can put in the full URL with the file name in it and it won't open either.

 

So I figured there was some install problem.  I uninstalled it, and not having the FMS 15.0.3 installer, I had to go back to 15.0.1.119 to install it, of which of course would not install because the java installed with 15.0.3 was a later version and FMS 15.0.1.119 will not let you proceed.  So annoyingly, I uninstall java and then start the 15.0.1.119 install again including it's older version of java.  After setting up the server, I stop it, and then run the FMS 15.0.3 updater, which installs the new java that I had to previously uninstall (so much for wasted time).  Vwala!!!!  I'm up and running.  But to make sure all is good, I stop the files and restart the Mac.

 

Time to go test WebDirect... and... nope!  Still doing the same thing.  FYI, I'm using the default install Safari 10.1 (12603.1.30.0.34) that comes with Mac OS X 10.12.4.

 

This is a plain Mac Mini with nothing added to it.  I even removed some of the iMovie/Keynote/Numbers stuff.  It does not have the Server.app (never has) and have not set up any web pages with it or otherwise manipulated Apache.  It did come as Mac OS X 10.11 and has been upgraded from there, but nothing unusual and it is a stock machine.  The only application ever installed on it is FileMaker Pro (15.0.3) that I use for testing purposes only.

 

I will mention that Base Elements plugin is installed (v 3.3) on FileMaker Server.  But turning it off hasn't made a difference in the WebDirect behavior.

 

Interestingly, the log file does not make any entries showing I've attempted to open a file or failed to open it.  If I look at the Activity while trying to WebDirect in, it does not show any WebDirect users there either.

 

For kicks and grins, I tried connecting via domain name and IP, and even from server machine using localhost.  But that didn't make a difference either.  All gave the same result.

 

The only thing different I did on the FMS install is that I turned off ODBC since it is not needed for this solution. I've verified the solution is setup to share WebDirect in the FileMaker WebDirect Settings.  I never get to the credentials prompt, but if I did, I would log in as [Full Access].  Also, I've confirmed the file is not auto-login. 

 

Any suggestions out there?  Maybe I overlooked something obvious.

Outcomes