AnsweredAssumed Answered

Missing added field from an external FMP database table.

Question asked by estrelralph on Apr 21, 2017

Hello.

 

First, I want to say thank you ahead of time for any feedback.   Please know I'm a Sr. Systems Analyst and Oracle Developer for about 19 years.  I have recently decided to expand into the FileMaker Pro arena and I'm quite enjoying it.   I'm still in the learning stages or FileMaker Pro Advanced, yet have learned a lot in a short time. 

 

I've come across an issue and I'm not quite certain how to correct it, here is the scenario...

 

I have a FMP server with two databases, we'll call them db1 and db2.   db1 is used for desktop use and is much more robust than db2.  db2 is simply used to capture some minor information through a mobile phone, yet it references and is dependent on one table in db1 (we'll call it table-A).  This was accomplished by setting up an external database connection from db2 to db1 and it works great.  The mobile form in db2 can reference fields found in db1/table-A just fine.

 

However, in db1 I have recently added a new field to table-A. the same table that db2 references through table relationships.  Yet, the newly added field found in db1/table-A is not showing in the pick list of the same referenced table object in db2 under table relationships.   The previous existing table-A fields are visible, yet the new field isn't.

 

In db2, I have tried deleting and recreating external database links and nothing happens.  Within table relationships, I've tried deleting the referenced table object and the recreating it and nothing.   I only see the original set of fields.

 

What am I missing?

 

Thanks,

 

Ralph

Outcomes