4 Replies Latest reply on Apr 28, 2017 6:01 AM by DanielShanahan

    Importing Cached Records?

    DanielShanahan

      I'm working on a local file.  In one table I have 7023 records.  A script reduces that to 101 records.  I need to import data from those 101 records to other tables.  However, FM imports 7023 records and not 101.  See screenshots.

       

      Machine:

      Mac Mini 20014

      10.12.4 (Sierra)

      2.6 GHz Intel Core i5

      8 GB 1600 MHz DDR3

       

      FileMaker:

      FMPA 15.0.3.305

       

      ------------------------------

       

       

      01 - Initial Record Count

      01_Initial_record_count.png

       

       

      02 - Finding and Deleting Records

      02_Deleted_unwanted_records.png

       

      03 - New Record Count After Delete

      03_New_record_count.png

       

      04 - Importing From Itself (currently a non-hosted file for testing)

      04_Importing_from_itself.png

       

      05 - FMPA Imports Initial Record Count of 7023 (importing cached records?)

      05_Imports_cached_records.png

        • 1. Re: Importing Cached Records?
          mardikennedy

          Hi Daniel,

           

          If it's any consolation to anyone, I haven't been able to recreate this in Windows 7.

           

          Background:  I have a solution in a Windows environment with some very similar scripting.  I pulled down a backup from the FMS12 server and opened the file locally in FMPA 15 (W7 WS).  I ran multiple import runs, with multiple Quits/ Exits in between, to try and trigger caching behaviour.

           

          I also adjusted scripting; in my normal one, the entire procedure happens within a single script whereas in yours, you appear to have an Exit after the deletion(s) from the Import Table.  I also added this structure eventually, as nothing else seemed to trigger adverse caching behaviour.  Even that worked perfectly.

           

          Note:  besides the completely different OS, the local FMPA is 15.02.

           

          Regards, Mardi

          • 2. Re: Importing Cached Records?
            DanielShanahan

            Thanks for taking the time to test, Mardi.

            • 3. Re: Importing Cached Records?
              ChrisMoyer

              Have you considered the possibility that you're cross-talking with another version of the file (hosted perhaps) that still has 7023 records in it? What do your external file references show for the path?

              • 4. Re: Importing Cached Records?
                DanielShanahan

                I think that was it, Chris.  The import script step had a legacy File Path.  I added another file path and although they look the same (see image), they apparently were not (I removed the top file path before re-testing).  Once I re-specified the File Path for all the imports, it brought in 101 records, as expected.

                 

                Thanks!

                 

                Screen Shot 2017-04-28 at 8.46.41 AM.png