0 Replies Latest reply on May 2, 2017 4:55 PM by ChrisMoyer

    FileMaker 15v3 updater problem with Apache on Sierra

    ChrisMoyer

      Just ran into this issue and it was a pretty obscure problem with a specific set of circumstances, but I thought I'd post it here in case it helps anyone down the road.

       

      The scenario: I needed to install FileMaker 15 on a new Mac Mini running Sierra, but only had a FileMaker 15v1 installer handy. It was duly installed, deployed, and everything worked fine. All WPE services were enabled: WebDirect, XML, PHP. After shutting down the server and WPE, I ran the 15v3 installer. It paused the install, needing Apache to be shut down. The usual apache commands didn't work because it's FileMaker Server's Apache install, so I just used to the Activity Monitor to quit Apache. The installer then proceeded to complete the upgrade.

       

      Post-upgrade, Apache wasn't running. It was possible to get 'regular' Apache running using the Terminal and:

       

      sudo apachectl start

       

      ...but that wasn't the version that FileMaker Server was utilizing, so not helpful. I ran:

       

      cd "/Library/FileMaker Server/HTTPServer/bin"

      sudo ./httpdctl start

       

      ...and got this error:

       

      /usr/sbin/httpd -k start -D FILEMAKER -f /Library/FileMaker Server/HTTPServer/conf/httpd.conf

      httpd: Syntax error on line 476 of /Library/FileMaker Server/HTTPServer/conf/httpd.conf: Could not open configuration file /Library/FileMaker Server/Web Publishing/publishing-engine/php/null/httpd.fmi.conf.php: No such file or directory

       

      The directory at /Library/FileMaker Server/Web Publishing/publishing-engine/php contains these folders:

       

      el capitan

      sierra

      yosemite

       

      ...and the path in the error above has 'null'. It seems the v3 updater failed and didn't insert the appropriate OS name.

       

      After modifying line 476 of httpd.conf by replacing 'null' with 'sierra', Apache started properly and starts up after a reboot. And XMP and PHP are working as expected.