7 Replies Latest reply on May 5, 2017 3:50 PM by philmodjunk

    Format of summary count field is incorrect

    sfeoc

      Siimple database showing annual dues paid by members. I have a summary field in the header that calculates the total in dollars of the found set. I also have a COUNT which should show a total count of members who have paid.

       

      But the COUNT summary is reporting as dollars, with a dollar sign. The number is correct, but why is there a dollar sign there? I can't think when a count summary would ever show in dollars.

       

      What am I doing wrong and/or how do I get rid of the dollar sign?

        • 1. Re: Format of summary count field is incorrect
          mikebeargie

          Under the inspector, data tab, bottom of the list are the field formatting options. You have the field formatted as currency instead of decimal, or "as entered".

          • 2. Re: Format of summary count field is incorrect
            sfeoc

            This is in the master table layout where summary fields are in the header. It has always been awkward that in table view there is no "Edit Layout" button, though command-L goes there.

             

            The fields are set as "General", but the dollar sign still shows in table view. If I click on the field, the proper COUNT number shows, but as soon as I click somewhere else, the dollar sign reappears.

            • 3. Re: Format of summary count field is incorrect
              philmodjunk

              What you describe when you click into the field is exactly the behavior of a field with currency number formatting specified in the inspector.

              • 4. Re: Format of summary count field is incorrect
                sfeoc

                But I don't know how to format a summary field in a table view.

                 

                Viewed as a Form, which shows one record, the COUNT summary fields are correctly showing as numerals, not dollars.

                 

                But viewed as a Table, there are dollar signs in the COUNT fields.

                • 5. Re: Format of summary count field is incorrect
                  philmodjunk

                  Enter layout mode

                  find the field on your layout and add it to your layout if it is not their.

                  Now format the field as you would with any other layout.

                  • 6. Re: Format of summary count field is incorrect
                    sfeoc

                    Enter layout mode from which layout? If I'm looking at the Table and enter Layout mode, it goes automatically to the Form display. And, as I said, the summary COUNT fields are correctly formatted there and correctly displaying. When I go to the Table view of the same data, the summary COUNT field shows $$$ signs. Filemaker has yet to fully integrate the logic and formatting of fields in Form view versus Table view. I don't know any way to address the specific layout settings of the Table view.

                    • 7. Re: Format of summary count field is incorrect
                      philmodjunk

                      Changing the view does not change to a different layout. Yes, when you enter layout mode, the layout looks nothing like what you see in table view. But you can still place a field on the layout while in layout mode, select data formatting options for it, and when you return to Table View, you should see the data formatted as specified for the field.

                       

                      If you have checked the formatting of the summary field while in layout mode and it looks correct, check to see if maybe you have two copies of this field on your layout as perhaps one is formatted as currency and one is not. (Or you are checking the wrong field object by mistake--that can be an easy mistake to make.