AnsweredAssumed Answered

Privilege violation error from applescript on FMP16

Question asked by kcrawley@citychannel4.com on May 9, 2017
Latest reply on May 9, 2017 by kcrawley@citychannel4.com

I have a rather convoluted legacy applescript that's been around since maybe FMP10, and it's the reason that any FMP or OSX updates scare the heck out of me...

 

Sure enough, it's broke again on FMP16.  I think the applescript in question is trying to call an FMP script when it generates this error..

 

"A privilege violation occured.  Filemaker Pro got an error: A privilege violation occured. (-10004)"

 

It relies on data from a remote server.  I tried using my own machine as the server and the client, but I get the same error.

 

I'm wondering if it's related to the message I get when I try to connect to the server:

 

'The connection to "CBL-KevinCrawley.local.5003" is not encrypted

This connection is not encrypted and should be used for testing purposes only.  Do you want to connect anyway?'

 

There is a ghosted "View Certificate" button, but no explanation, and I can't  find anything about it in the FMP16 documentation.

 

Any advice would be appreciated.

Outcomes