AnsweredAssumed Answered

Go To Related Record not taking me to the correct record

Question asked by roryduffy on May 10, 2017
Latest reply on May 10, 2017 by philmodjunk

Hi,

Apologies if this question has been answered already elsewhere. I've been using the "Go to Related Record" function (both within a script, and as a single action button).

 

Recently, it's not been working correctly. It takes me to the correct layout, but not the correct record.

 

For example, in the screenshot, no matter which "event record" I click go next to on 04/05/2017, it always takes me to the 1st event record in that portal (in this case, Matthew Halsall).

 

I've investigated the following

  1. Checked that the GO button is performing the correct script (GRR_BOTW2_Functions_Production_0031).
  2. Re-configured the button from a script to a single Go to Related Record action.
  3. Checked that in both cases the Go to Related Record is taking you to the correct table (events).
  4. Checked that the button is embedded correctly in the portal, i.e., moved the button inside the portal and tested dragging the portal to check that the button moves with the portal.
  5. Checked that the event fields are also inside the portal and are moving with the portal.
  6. Tried moving the button so that none of its edges are touching the edge of the portal.
  7. Checked the sort order of the portal and tried unchecking the sort portal records in case that made any difference.
  8. Went into the relationships graph and checked that both relations of the key linking Dates to events (i.e., Dates --> Dates_Events --> Events) are not sorted.
  9. Checked other layouts in which this diary view occurs and it is happening elsewhere.
  10. Checked the File Options.
  11. Checked that all affected layouts don't have other script triggers running that interfere with anything. At the moment, they only have a Set Variable Script trigger (used in a "Backwards" script) - which shouldn't affect it.

 

I'm using Filemaker Pro v14 on a server-hosted solution. It's quite a large, old solution (est. 2012) so I'm wondering whether it's something to do with indexing and maybe the file has reached its capacity? If that's the case, is there a way to clean out indexing? If that's not likely to be the issue then my apologies, or whether it's a bug with v14, but I can't think of any other reason why the Go to Related Record wouldn't be taking me to the correct record as it's only started doing this recently.

 

Many thanks,
Rory

Attachments

Outcomes