realgrouchy

FM Go 16: Insert from Device (QR code) with global field

Discussion created by realgrouchy on May 15, 2017
Latest reply on Jul 10, 2017 by user28506

I just installed FM Go 16 on my iPad 4 (which required me to upgrade to iOS 10.3.1).

 

My database, which I access via a local network share off my FMPA 16 install on an iMac, uses a global field in the current table to temporarily store the result of a QR Code scan in order to find the record with the name associated with that result. The Global field is located on the layout, 'hidden' behind a button bar.

 

In FM Go 15 this works fine, as it has done since I created the scanning script, including after trying and failing in FM Go 16 on the same device.

 

In FM Go 16, the "Insert from Device" step does not insert the data into the global field, and as a result it can't validate or look up that data (I included a pause script step immediately after to verify it wasn't being deleted etc.). It does this even after trying and succeeding to do this in FM Go 15 on the same device.

 

In the script, I tried toggling the settings in the Insert from Device step, and that did not help.

 

When I redefined the field from a Global field to a non-Global field, the script step worked in FM Go 16. When I changed it back to a Global field, it continues to work, even after I close the file and restart FM Go 16.

 

When I open a copy of the database (with different data) where I didn't toggle the field to non-Global and back, it also works without problem. (And I never opened that file before in FM Go 16).

 

I also tried uninstalling and reinstalling FM Go 16 (although without restarting the iPad) but could not reproduce the problem again. I did get the "FM Go wants to use your device camera" warning/prompt.

 

Since the thing I did seems to have fixed it for me, I'm not sure how I can reproduce the problem. Maybe there's a one-time issue about the camera needing to scan to a non-global field before it can scan to a global field. But I don't want to encounter this issue in a situation where I don't have access to FMP to fix it.

 

Edit: about an hour later, after my iPad timed out, the problem happened again. Toggling the field to Global and back didn't work. For the time being, I'll continue to use FM Go 15.

 

- RG>

 

Message was edited by: RealGrouchy

Outcomes