AnsweredAssumed Answered

Filemaker Server 16 and PDF Container Fields Not Working

Question asked by ken.bailey on May 18, 2017
Latest reply on Nov 19, 2017 by HOnza

My question is this: Is anyone else having problems with container fields not showing with inserted PDF? Almost as if it is not communicating with acrobat correctly?

 

Here is some background: First, we have a field that is used to collect scanned documents as PDFs. We were using Server 14 and the container field was set to Data Formatting / Interactive Content. This solution is on a server and the user, using FMP on a client would drag over a PDF into the container field and it would show the PDF with the ability to scroll through the pages and zoom. This worked great.

 

This last week we upgraded to FMS 16 and the PDFs will not show up and now you get a blank container field with a load bar at the bottom - The same bar that was used for the scrolling and zoom - and nothing else. The only option on the field is to reload.

 

If I switch the formatting of the container field to optimize for images, the PDF shows, but sideways. If you export it, it is properly formatted and rightsize up.

 

This morning I created a local test database with a container field and loaded a PDF into the field and it worked fine. I also tested the web direct option of my original database and when using the web the PDF shows correctly. I uploaded the test database to the server and the issue is the same - I can't see the PDF using FMP client to FMS.

 

It seems like acrobat is "hanging".

 

Can anyone help me with either a solution or an understanding of what might be occurring. Also please note that this issue is replicated of several other computers, some using FMP15, FMP16 and FMP 14. I believe this is a server side issue.

 

I have attached a screen shot of what I am getting.

 

Thanks,

Ken

Outcomes