AnsweredAssumed Answered

Opening Script via Internet Protocol (FMS) Method Stopped Working in FM 16?

Question asked by tigtillinghast on May 22, 2017
Latest reply on May 25, 2017 by tigtillinghast

Hi, I have a solution that uses the FMP internet protocol to trigger a script. Normally this is done to trigger a script in an external file, but I'm actually triggering a script in the same file so as to enable the solution to record data acquired via a Javascript action happening in a web viewer.

 

So, the user clicks on the web viewer to note the latitude and longitude they wish to record. The Javascript extracts that data and then sends it as a parameter to the script, which just inserts that data into a field in the database.

 

This all worked great until FM 16 came out, and now it won't trigger the script under the new version.

 

Here is the URL being run in the viewer that once worked and now does not...

fmp://$/fileName?script=scriptName&param=" + event.latLng

 

I thought at first it had to do with the new privileges stuff that has been added, but I've added the extended privileges (all of them), and it still does not work.

 

Could it be that the $ part no longer is working as a stand-in for the directory location?

 

Any advice greatly appreciated. Thanks!

Outcomes