2 Replies Latest reply on May 24, 2017 1:09 PM by Michael Frankel

    FMS16 on Amazon EC2 - 2-Machine Deployment

    Michael Frankel

      Hi Everyone -

       

      I'm setting up a 2-machine configuration for Web Direct (i.e., Master + Worker) on Amazon EC2. I've installed Windows Server 2016 for both instances, and am using FileMaker Server 16.

       

      I installed the master machine first, didn't deploy it, installed the worker machine, didn't deploy it, then deployed the master machine (which went fine), then attempted to deploy the worker machine (not so well).

       

      For reference, I am using Elastic IPs and have associated each one with one of the EC2 instances.

       

      Both instances are on the same VPC.

       

      I can connect to the Master machine, but keep getting "Connection Timed Out".

       

      I know I'm getting connected to the Master machine because I'm getting prompted about there being a self-signed SSL certificate there.

       

      I've watched and read so many videos about this my head is swimming. I've opened up all the ports, both in Amazon's security groups and in the Windows Firewall.

       

      Any assistance or guidance anyone can provide?

       

      Thanks,

      --

      Michael Frankel

      Wizard Consulting Group, Inc.

        • 1. Re: FMS16 on Amazon EC2 - 2-Machine Deployment
          Mike Duncan

          Do you have all the necessary ports open, both in the Windows Firewall as well as any security groups you have set up?
          Remember to include ports 16002 and 16003. These are documented on page 23 of the FMS 16 install guide.

           

          And do you have any DNS set up? You might set up a couple A records to point to the EIPs you have on your machines now. If not using SSL, you can check the box that comes up about bypassing the cert when connecting.

           

          Thanks
          Mike

          • 2. Re: FMS16 on Amazon EC2 - 2-Machine Deployment
            Michael Frankel

            Thanks, Mike.

             

            I also got some help on another discussion group from Jesse Barnum. Your suggestions echoed his.

             

            The solution that worked for me was:

             

            1. Turn off the Windows Firewall on both machines.
            2. Add all of the ports specified by FileMaker's documentation to the associated Security Group in EC2.

             

            Doing that solved it.

             

            Thanks for your input.

            --

            Michael Frankel

            Wizard Consulting Group, Inc.