1 2 Previous Next 23 Replies Latest reply on Jul 11, 2017 6:13 PM by kupietz

    FMPA 16: Cannot Edit Tooltips on Buttons

    richardsrussell

      Just installed FMP Advanced Version 16 and am trying to use it to edit buttons. I've got a set of buttons that insert arrows into the current cursor location. They make a nice little cross shape:

      4 Arrows.jpeg

      (The one in the middle inserts a bullet.) I wanted 4 more for the diagonal arrows, so I adopted the tested, tried, and true method of duplicating one of them and editing it 4 times to produce the desired array:

      8 Arrows.jpeg

       

      And there was no problem editing either the text on the face of the buttons or their actions. They all do exactly what I want. The last remaining step was to edit the tooltip on each one so it describes what it actually does, and this is where I ran into the brick wall. They all still show the tooltip that's associated with the original button that I duplicated, and I can't edit it. Furthermore, I can't go back and edit the tooltips on the original buttons, either.

       

      "Aha!", I thot, "this must be one of those things that the spiffy new Layout Objects window handles now." So I went there, selected the object, and tried right-clicking on it to bring up a contextual menu, but no go. It doesn't provide me with an option to edit the tooltip:

      Layout Objects Window.jpeg

       

      Well, dang! How DO I edit the tooltips on my buttons? Because pretty much every database I've ever created has a tooltip on every button on every layout (yes, thousands and thousands of them), and my users take it for granted that they'll work 100% of the time with 100% accuracy.

       

      I've gotta say that, if this is an inherent feature of FMP 16, I'm gonna warn everybody away from it.

        1 2 Previous Next