JulianJohnson

Configuring Filemaker Server 16 with GoDaddy Certificate

Discussion created by JulianJohnson on Jun 4, 2017
Latest reply on Jun 5, 2017 by Datagrace

Hi All,

 

I'm struggling to get a Filemaker Server 16 installation to use a certificate from GoDaddy. I'm sure it's something I'm doing but can't find any instructions that seem to match the options that FM and GoDaddy offer.

 

What I've done so far:

• I've been to the Admin Console>Database Server>Security and checked SSL. Then selected Create Request.

• I put in our domain name (not the FQDN, so not server.domain.com but used domain.com), company name and password.

• I generated and downloaded the serverRequest.pem file.

 

• I then went to GoDaddy and pasted the contents of the serverRequest.pem file into the new certificate window and waited for them to approve it.

• I chose server = other and downloaded the certificate from GoDaddy and received a zipped folder containing two files: one with a load of letters/numbers as the name and one called gd_bundle-g2-g1.

• I then went back to the Admin Console and clicked Import.

 

I've then tried the following to get it to work:

• Selecting the downloaded file with all the letters and numbers as the certificate file.

• Selecting the gd_bundle-g2-g1 file as the intermediate file and not selecting it.

• Concatenating the contents of the two files into one called chain.pem and using that as the certificate file.

• Entering the password that I used when creating the serverRequest file in the first place.

 

Initially I get a message telling me that the serverRequest.pem file already exists so I have removed that from the CStore folder, I still get the message.

I've also tried removing the serverKey.pem file from the CStote folder, that seems to resolve that issue.

However, I then get a message telling me that the password doesn't match the one I used when generating the request, however I know it does and have done the whole process three times.

 

I've also tried it on the Admin Console running on a remote Mac here and also by RDC onto the server itself and doing the whole process there.

 

For info, it's Filemaker v16, running on Windows Server 2012 R2 on an AWS EC2 Instance.

 

I don't know what on earth to try next! Has anyone had this working and are there any tricks that hopefully don't involve command line type stuff?

 

Thanks in advance for any help......

 

Kind Regards

Jules

Outcomes