3 Replies Latest reply on Jun 13, 2017 10:10 AM by greglane

    Import table via ODBC where a single field is protected

    weltwanderer19

      I am trying to import particular fields from a table (Patient) that contains medical information. In this table, there are names (which are protected fields in the mysql database) and other non-protected fields, such as IDs. I have successfully setup the mysql database as an external datasource. Currently, I am running FMPA 16 on my mac, which I remotely connect to a windows server that hosts the FM database. On the windows server I have ODBC setup to connect with the mysql database.

       

      I have been able to import tables into the relationship graph, including the Patient table. However, in the Patient table, all fields contain the same error message: [MySQL][ODBC 5.1 Driver][mysqld-5.1.73]SELECT command denied to user '(my username in here)' for column 'LastName" in table 'Patient'

       

      This message is present in all records and fields of this table (just this table, other imported tables are fine). I have tried a different import method by going to 'import records,' however the external datasource does not show up because it is not my computer that is connected through odbc with the mysql datasource (it is the windows server).

       

      Is there some workaround to this issue? I tried to install the mysql odbc connector on my mac but the install repeatedly fails. Maybe this is a port issue? Is there a better way to import records into FileMaker from the Patient table without including the Lastname field?

       

      The last resort will be to export from the mysql database directly. But this would lessen the independence of the FM database as this import will need to occur regularly.

       

      Thanks,

      WW