justinc

FMPA 16.01 Style corruption after copy/paste object

Discussion created by justinc on Jun 21, 2017
Latest reply on Jun 23, 2017 by justinc

I ran into an odd problem with applying Styles to layout objects in FMPA 16.01.

 

I was creating a new layout and had applied a new-ish Theme to it.  This is a Theme that I created, with Styles mostly (all?) created from scratch.  (I wasn't exactly specifically creating it with the idea that I would clear out all the original stuff, but that's pretty much what I did.)  I believe that I created this Theme in 15.03.

 

I created a new layout a couple of days ago and based it on this new Theme.  I was going along nicely, no real problems.  I then happened to copy a field from an older layout and pasted it onto this newer layout; it had Theme/styles from another Theme, of course.  I then tried to apply a Style from the current Theme to this new object, but it wasn't taking the full Style - specifically, it was not accepting the vertical alignment setting.  The Style was set for Vertical = Top, but this object was getting Vertical = Middle.  There was another field that I had copied over from that same source layout - it had no trouble accepting the full styling for this particular Style.  I did some gyrations of toggling to Default, then picking this Style, etc, but this particular field would never apply the full Style and would always get Vertical = Middle.

 

New fields that I put on the layout have no trouble.

I shut down FMPA 16.03 and restarted it - no change.

 

FMS 15.03

FMPA 16.01

Style created in 15.03 (I think - wasn't really paying attention at the time)

 

I created a little video showing the issue.  It's ~6.5MB in size; let me know a place to send it to if you want to see it.  I can probably get you a clone copy of the file, too.

 

Thanks,

Justin

Outcomes