1 2 Previous Next 17 Replies Latest reply on Jul 11, 2017 7:16 PM by user19752

    FMS15 first boot, can't configure IIS

    barabba

      Hi, I've complicated issue.. and I don't understand why FMS contribute to raise it and doesn't offer a clear help to solve it.

       

      Once FMS15 installed I open its admin console at 127.0.0.1:16001 , there I stop at the 5th stage about testing the IIS server, it pretends to open the page http://127.0.0.1:80/fmi-test/test.xml , now the IIS has by default disable the browsing of subfolders, so I ca open a generic 127.0.0.1/index.html but I can't make work anything like 127.0.0.1/subfolder/index.html , of course the path exist on the published root folder, as well as files, etc. Even permissions of files are set correctly.

       

      I tried to google and I've found how to change settings inside IIS like allow the browsing of directory, but it still not work.

       

      How FMS pretend that an IIS installed as default (without customizations) can work with such path? Why nobody explained how to setup properly IIS to work with FMS?
      I have an error 500.

       

      Thank you for help

        • 1. Re: FMS15 first boot, can't configure IIS
          wimdecorte

          barabba wrote:

           

           

          Once FMS15 installed I open its admin console at 127.0.0.1:16001 , there I stop at the 5th stage about testing the IIS server, it pretends to open the page http://127.0.0.1:80/fmi-test/test.xml ,

           

          I'm not sure I follow your description of the problem.  Can you post a screenshot of where it goes wrong on that '5th stage'?  It sounds like you are talking about the deployment wizard.  That one does do a web server test but it does not open the text.xml page.  That's where I don't follow you anymore.

           

          Either the web server test succeeds and you can continue with the deployment, or it fails and you can fix it or disable web publishing.

           

          So show us the fail message if that is what is blocking you.  And explain how you attempt to fix it.

          • 2. Re: FMS15 first boot, can't configure IIS
            bigtom

            Not sure if it makes any difference but I never open the admin console from 127.0.0.1. I use the actual machine IP address. If you are working directly in the server use localhost:16001.

             

            Sometimes things go go wrong in windows. I have been on the phone with FMI tech support a couple times. After double checking everything the final advice they had was to keep removing and installing FMS until it worked. Another time it was remove and install the OS and FMS until it worked.

             

            Now i I keep a working image file of windows with FMS installed handy.

            • 3. Re: FMS15 first boot, can't configure IIS
              barabba

              thank you for kind help,

              I attach screenshot, it fails when try to open the xml and this is right, cause I also can't open it with browser. The reason is that IIS can't open subfolders, in this case the subfolder "/fmi-test/". If I put the xml file in the root it opens, but who can tell FMS to open it on the root folder? Nobody, so it fails.

              The problem is not in FMS but on IIS, I need a way to open subfolders that existing on the path where the root is located. For example, the root is C:\root and it contains the file index.html, there is also a folder c:\root\1 and it containd the file index.html. All files and folders have right and same permissions.
              Now I can open 127.0.0.1/index.html but I can't open 127.0.0.1/1/index.html
              I hope it is clear.

               

              I'm complaining with FMS because in their guide it is just write how to install IIS but not how to configure it to see subfolders. Do someone know here how to configure IIS to open the subflders too? thank you a lot!

              fms.jpg

              • 4. Re: FMS15 first boot, can't configure IIS
                barabba

                I thappens with its IP appress 10.0.3.250 and also with 127.0.0.1.
                I already set "browse.subfolders=true" on IIS configuration.

                • 5. Re: FMS15 first boot, can't configure IIS
                  wimdecorte

                  I think you are chasing the wrong thing.  The issue is NOT where that XML file is located, it's that FMS can't communicate with IIS. Do you have existing websites on that IIS or is this a fresh install of Windows with nothing else on it?

                  • 6. Re: FMS15 first boot, can't configure IIS
                    user19752

                    fmi-test is not sub folder of webroot.

                     

                    Agreed to @wimdecorte, IIS is configured thru deployment of FMS, so if you already used IIS, try uninstalling IIS before installing FMS.

                    • 7. Re: FMS15 first boot, can't configure IIS
                      bigtom

                      I will second the idea of fully removing anything thing that FMs will

                      need. I had to remove IIS and a couple C modules once.

                      • 8. Re: FMS15 first boot, can't configure IIS
                        CarlSchwarz

                        barabba wrote:

                         

                         

                        The problem is not in FMS but on IIS, I need a way to open subfolders that existing on the path where the root is located. For example, the root is C:\root and it contains the file index.html, there is also a folder c:\root\1 and it containd the file index.html. All files and folders have right and same permissions.

                         

                        I'm complaining with FMS because in their guide it is just write how to install IIS but not how to configure it to see subfolders. Do someone know here how to configure IIS to open the subflders too? thank you a lot!

                         

                        FileMaker server will configure IIS for you when it installs properly (sometimes it just fails).  You should not have to do anything to IIS because FileMaker will do it all for you.

                        After FileMaker server installs your default web directory will change to C:/Program Files/FileMaker/FileMaker Server/HTTPServer/conf

                         

                        Do note that I have issues the the FileMaker installer is not run from the C:, make sure your installer is run from the C:

                        • 9. Re: FMS15 first boot, can't configure IIS
                          barabba

                          Thank you everyone, I uninstalled it and assured it removed also the internet site on IIS, installed from C:\,  the situation is the same.
                          I noticed that when it created the IIS site, it sets the root to: C:\Program Files\FileMaker\FileMaker Server\HTTPServer\config , inside this path no subfolders, there is a web.config (read later) if I try to open any single file like 127.0.0.1/TestPage.png it doesn't open. The file web.config contain wrong datas, if I use a simple one the file open, this is the first big problem.


                          The path the the test page pretend to open is /fmi-test/ and it is contained on the previous folder C:\Program Files\FileMaker\FileMaker Server\HTTPServer\fmi-.test. This is the second big problem, how it can prtend to open this folder if it is contained in another path?? (not the C:\Program Files\FileMaker\FileMaker Server\HTTPServer\config).

                          I don't believe FMS how it configure IIS, too many problems here, I prefer to setup manually IIS to let the page test access to the path it pretends. Can someone help me here with IIS config? Thanks

                          The web.config that FMS created and doesn't work:

                          <?xml version="1.0" encoding="UTF-8"?>

                          <configuration>

                            <system.webServer>

                              <rewrite>

                                <rules>

                                  <clear />

                                  <rule name="standby_http" enabled="false" stopProcessing="false">

                                    <match url="^hss(/(.*))?" negate="true" />

                                    <conditions>

                                      <add input="{HTTPS}" pattern="off" />

                                    </conditions>

                                    <action type="Redirect" url="http://{PRIMARY}:{SERVER_PORT}{REQUEST_URI}" />

                                  </rule>

                                  <rule name="standby_https" enabled="false" stopProcessing="false">

                                    <match url="^hss|fmws(/(.*))?" negate="true" />

                                    <conditions>

                                      <add input="{HTTPS}" pattern="on" />

                                    </conditions>

                                    <action type="Redirect" url="https://{PRIMARY}:{SERVER_PORT}{REQUEST_URI}" />

                                  </rule>

                                  <rule name="fmws" enabled="true" stopProcessing="false">

                                    <action type="Rewrite" url="http://localhost:1895/{R:0}" />

                                    <match url="^fmws(/(.*))?" />

                                    <conditions>

                                      <add input="{SERVER_PORT}" pattern="443" />

                                    </conditions>

                                  </rule>

                                  <rule name="oauth_SSL" enabled="true" stopProcessing="false">

                                    <action type="Rewrite" url="http://localhost:1895/{R:0}" />

                                    <match url="^oauth(/(.*))?" />

                                    <conditions>

                                      <add input="{SERVER_PORT}" pattern="443" />

                                    </conditions>

                                  </rule>

                                  <rule name="oauth" enabled="true" stopProcessing="false">

                                    <action type="Rewrite" url="http://localhost:1895/{R:0}" />

                                    <match url="^oauth(/(.*))?" />

                                    <conditions>

                                      <add input="{SERVER_PORT}" pattern="80" />

                                    </conditions>

                                  </rule>

                                  <rule name="standbyws" enabled="true" stopProcessing="true">

                                    <match url="^hss(/(.*))?" />

                                    <action type="Rewrite" url="http://localhost:1895/{R:0}" />

                                    <conditions>

                                      <add input="{SERVER_PORT}" pattern="443" />

                                    </conditions>

                                  </rule>

                                  <rule name="docws" enabled="true" stopProcessing="false">

                                      <action type="Rewrite" url="http://localhost:1895/{R:0}" />

                                      <match url="^docws(/(.*))?" />

                                  </rule>

                                  <rule name="Streaming" enabled="true" stopProcessing="false">

                                    <action type="Rewrite" url="http://localhost:1895/{R:0}" />

                                    <match url="^Streaming(/(.*))?" />

                                    <conditions>

                                      <add input="{SERVER_PORT}" pattern="80" />

                                    </conditions>

                                  </rule>

                                  <rule name="x_forwarded_proto_uac" enabled="true" stopProcessing="false">

                                    <match url="^admin-console(/(.*))?" />

                                    <conditions>

                                      <add input="{HTTPS}" pattern="on" />

                                    </conditions>

                                    <action type="None" />

                                    <serverVariables>

                                      <set name="HTTP_X_FORWARDED_PROTO" value="https" />

                                    </serverVariables>

                                  </rule>

                                  <rule name="uac" enabled="true" stopProcessing="false">

                                    <action type="Rewrite" url="http://127.0.0.1:16001/{R:0}" />

                                    <match url="(.*)" />

                                    <conditions>

                                      <add input="{SERVER_PORT}" pattern="16000" />

                                    </conditions>

                                    <serverVariables>

                                      <set name="HTTP_X_FORWARDED_HOST" value="{HTTP_HOST}" />

                                    </serverVariables>

                                  </rule>

                                  <rule name="Streaming_SSL" enabled="true" stopProcessing="false">

                                    <action type="Rewrite" url="http://localhost:1895/{R:0}" />

                                    <match url="^Streaming_SSL(/(.*))?" />

                                    <conditions>

                                      <add input="{SERVER_PORT}" pattern="443" />

                                    </conditions>

                                    <serverVariables>

                                      <set name="HTTP_X_FORWARDED_HOST" value="{HTTP_HOST}" />

                                    </serverVariables>

                                  </rule>

                                  <rule name="https_admin-console" enabled="true" stopProcessing="true">

                                    <match url="^admin-console(/(.*))?" />

                                    <conditions>

                                      <add input="{SERVER_PORT}" pattern="80" />

                                      <add input="{HTTPS}" pattern="off" />

                                    </conditions>

                                    <action type="Redirect" url="https://{SERVER_NAME}:16000/admin-console" redirectType="Found" />

                                  </rule>

                                  <rule name="https_test_page" enabled="true" stopProcessing="true">

                                    <match url="^test$" />

                                      <conditions>

                                        <add input="{SERVER_PORT}" pattern="80" />

                                        <add input="{HTTPS}" pattern="off" />

                                      </conditions>

                                      <action type="Redirect" url="https://{SERVER_NAME}:16000/test" redirectType="Found" />

                                  </rule>

                                  <rule name="https_admin-console_2" enabled="true" stopProcessing="true">

                                    <match url="^admin-console(/(.*))?" />

                                    <conditions>

                                      <add input="{SERVER_PORT}" pattern="443" />

                                      <add input="{HTTPS}" pattern="on" />

                                    </conditions>

                                    <action type="Redirect" url="https://{SERVER_NAME}:16000/admin-console" redirectType="Found" />

                                  </rule>

                                  <rule name="https_test_page_2" enabled="true" stopProcessing="true">

                                    <match url="^test$" />

                                      <conditions>

                                        <add input="{SERVER_PORT}" pattern="443" />

                                        <add input="{HTTPS}" pattern="on" />

                                      </conditions>

                                      <action type="Redirect" url="https://{SERVER_NAME}:16000/test" redirectType="Found" />

                                  </rule>

                                  <rule name="x_forwarded_proto" enabled="true" stopProcessing="false">

                                    <match url="^fmi/(webd|xml)(/(.*))?" />

                                    <conditions>

                                      <add input="{HTTPS}" pattern="on" />

                                    </conditions>

                                    <serverVariables>

                                      <set name="HTTP_X_FORWARDED_PROTO" value="https" />

                                    </serverVariables>

                                    <action type="None" />

                                  </rule>

                                  <rule name="https_webd" enabled="true" stopProcessing="true">

                                    <match url="^fmi/webd(/(.*))?" />

                                    <conditions>

                                      <add input="{SERVER_PORT}" pattern="80" />

                                      <add input="{HTTPS}" pattern="off" />

                                    </conditions>

                                    <action type="Redirect" url="https://{SERVER_NAME}:443/fmi/webd{R:1}" redirectType="Found" />

                                  </rule>

                                  <rule name="BlockConf" stopProcessing="true">

                                     <match url="^fmi/conf/(.*)" />

                                     <action type="AbortRequest" />

                                  </rule>

                                  <rule name="FMWebPublishing" stopProcessing="true">

                                    <action type="Rewrite" url="http://127.0.0.1:16020/fmi/{R:1}" />

                                    <match url="^fmi/(.*)" />

                                    <serverVariables>

                                      <set name="HTTP_X_FORWARDED_HOST" value="{HTTP_HOST}" />

                                    </serverVariables>

                                  </rule>

                                  <rule name="CWPHelp" stopProcessing="true">

                                      <action type="Rewrite" url="http://127.0.0.1:16020/fmwd_help/{R:1}" />

                                      <match url="^fmwd_help/(.*)" />

                                  </rule>

                                </rules>

                              </rewrite>

                              <httpProtocol>

                              <customHeaders>

                                <add name="X-Frame-Options" value="SAMEORIGIN" />

                              </customHeaders>

                              </httpProtocol>

                              <security>

                                <requestFiltering>

                                  <requestLimits maxAllowedContentLength="4294967295" />

                                </requestFiltering>

                              </security>

                            </system.webServer>

                          </configuration>

                           

                          The web config I used and works, but not with subfolders, unfortunately (help needed for that)

                           

                          <configuration>

                          <location>

                              <system.webServer>

                                  <directoryBrowse enabled="true" />

                              </system.webServer>

                              <system.web>

                                   <authorization>

                                        <allow user="*"/>

                                   </authorization>

                              </system.web>

                          </location>

                          </configuration>

                          • 10. Re: FMS15 first boot, can't configure IIS
                            bigtom

                            This is really pretty easy and hands off most of the time. Wipe the

                            Server. Fresh install of Windows Server. Install FMS. Open ports. It works.

                            1 of 1 people found this helpful
                            • 11. Re: FMS15 first boot, can't configure IIS
                              wimdecorte

                              You're completely over-thinking this.  Paths, folders and files inside the FMS structure don't need to change, the IIS config does not need to be changed manually either; the FMS deployment wizard does all that and puts everything in the right place.

                               

                              While I usually hate to say "wipe it" I would agree with bigtom at this point.  Start from scratch, it shouldn't be this difficult and it usually isn't.

                              1 of 1 people found this helpful
                              • 12. Re: FMS15 first boot, can't configure IIS
                                user19752

                                Now I'm curious for why this issue occurred, since I got same issue on installing FMS16 (not 15) on Win7 (of course, not supported I know, but I don't have supported one just now).

                                 

                                /fmi-test/ is an "application" in FMS15, it is routed to another location than web root,

                                C:\Program Files\FileMaker\FileMaker Server\Web Publishing\web-server-support\test\fmi-test

                                Is this same on FMS16?

                                 

                                There is only phptest.php file in the directory (FMS15 has test.xml), and installation didn't make "application" in FMWebSite.

                                • 13. Re: FMS15 first boot, can't configure IIS
                                  barabba

                                  Hi all, maybe someone is interested here about solution )

                                   

                                  As I was still "completely overthinking" and I insisted on that I've found the soution on IIS, which was far to be solved with "reinstall all since it will work".
                                  IIS 10 needs to put in all folders that will be browsed the file config.web, in the folder fmi-test thre isn't one so create a text file and add these lines:

                                  <configuration>

                                  <location>

                                      <system.webServer>

                                          <directoryBrowse enabled="true" />

                                      </system.webServer>

                                      <system.web>

                                           <authorization>

                                                <allow user="*"/>

                                  <bindings>

                                                      <binding protocol="http" bindingInformation="*:80:" />

                                                  </bindings>

                                           </authorization>

                                      </system.web>

                                   

                                  </location>

                                   

                                  </configuration>

                                   

                                  then rename it to config.web

                                   

                                  As second step open the Windows control panel, adinistrative tools, choose IIS there and in its control panel go to sites, FMWebSite, now click on the IIS authentication icon and enable all (anonymous autentication and .NET), do the same for the fmi-test subfolder.
                                  Done, now you can test the path with your browser

                                  • 14. Re: FMS15 first boot, can't configure IIS
                                    schamblee

                                    The IIS version that FMS installs is not compatible with Windows, it is for Windows Server.   Install IIS first, it comes with the professional version of Windows, it's not installed by default.   You can Install IIS by clicking Windows Features in Advanced Options under Programs in Control Panel or Download Copy from Internet.   After IIS has been install then install FMS. 

                                    1 2 Previous Next