2 Replies Latest reply on Jun 29, 2017 11:58 AM by tcwaters

    Check box data that displays in FMP does not display in WebDirect

    tcwaters

      I was looking over how layouts of a solution show in WebDirect, when I noticed a data discrepancy.  The attached image shows a layout in FMPro 16 (left), Internet Explorer (middle), and Win Chrome (right). The field "nameInstructor" is chosen from a value list.  In FMPro, the layout shows the data correctly- there are checks next to several names, but the same record in WebDirect does not show the boxes as checked.

       

      The correct values are in the value list, but the data that already exists in the field is not displayed. While my example image attached shows WebD in IE and Win Chrome, Safari and Chrome on Mac, look similarly.

       

      The value list shows values from a related table, and was set to use two fields (nameLast and nameFull) , but only display the second (nameFull).  If I change the value list to use only one field, it displays properly in FMP as well as WebD.

       

      This is FMS 16 server and FMP 16

        • 1. Re: Check box data that displays in FMP does not display in WebDirect
          TSGal

          tcwaters:

           

          Thank you for your post.

           

          I am unable to replicate the issue.  This is what I have done:

           

          1. In FileMaker Pro 16 under macOS Sierra 10.12.5, I created a database file with the following tables and fields:

            Table

               ID (Number - Auto-enter serial)

               Name (Text)

               Checkbox (Text)

           

            Friends

               ID (Number)

               First Name (Text)

               Last Name (Text)

           

          2. The Relationships graph links Table::ID to Friends::ID

          3. In the Friends table, I created the following records:

              ID - First Name - Last Name

              1 - Amy - Arnold

              1 - Betty - Boop

              1 - Connie - Conrad

              1 - Debbie - Davis

              1 - Erica - Ervin

           

          4. In the Table table, I created one record with ID=1 and Name="TSGal"

           

          5. In Layout mode, I formatted the Checkbox field to be a Checkbox Set, using values from fields "Friends::First Name" and "Friends::Last Name", including only related values from "Table" and showing values only from second field.

           

          6. In Browse mode, in the Checkbox field, I selected "Boop" and "Davis".

           

          7. I turned on Network Sharing and WebDirect access.

           

          8. I turned off File Options Log in, and I assigned a password "admin" to the Admin account.

           

          9. I uploaded the file to FileMaker Server 16, and opened the hosted file via FileMaker Pro 16.  The Checkbox field appears as expected.

           

          10. I launched Chrome and opened the hosted file via WebDirect.  The Checkbox field appears as expected.

           

          Let me know what I am doing differently than you so I can try to replicate the issue.

           

          TSGal

          FileMaker, Inc.

           

          Screen Shot 2017-06-28 at 10.01.39 AM.png

           

          Screen Shot 2017-06-28 at 10.00.34 AM.png

          • 2. Re: Check box data that displays in FMP does not display in WebDirect
            tcwaters

            I created a new test file like yours and it works as expected- just like you demonstrate. I then looked at what may be different fin my real database and the test file.  The only thing I see is that the field shown in the value list is a calculation field (name first  & " " & name last)

             

            But I tried that in the test file, and it still works.  So, at this point I can't replicate the issue.

             

            There are some differences in my real file and the test file, for example, the valuelist comes from a join table, but That in and of itself doesn't seem to me to be a cause.  I'll keep trying to replicate the issue.