7 Replies Latest reply on Jul 7, 2017 11:31 AM by ADNPlus

    FMS 15 - Additional Database Folders does not work.

    ADNPlus

      OS: Win2012SrvR2

      FMS 15.0.3.308

       

      After adding the correct path to the console field for Additions database folder 1

       

      a. The validate path button does nothing. You click it and it's like clicking on a picture. It's basically in a coma state. Other areas of the console work, properly.

       

      b. The path is verifiably correct as the exact configuration is in use in a test server, although that one uses FileMaker Server 16, but it's a feature that's been around for a few versions.

       

      c. The path is on a local drive (no fancy external drives or unsupported shenanigans like shared network folders, I mean who uses those in an office anyways)

       

      We have restarted the server already.


      Anyone seen & solved this?

       

      Thanks!

        • 1. Re: FMS 15 - Additional Database Folders does not work.
          wimdecorte

          Can you upload a screenshot?

          • 2. Re: FMS 15 - Additional Database Folders does not work.
            steveromig

            OS: Win2012SrvR2

            FMS 15.0.3.308

             

            After adding the correct path to the console field for Additions database folder 1

             

            a. The validate path button does nothing. You click it and it's like clicking on a picture. It's basically in a coma state. Other areas of the console work, properly.

             

            b. The path is verifiably correct as the exact configuration is in use in a test server, although that one uses FileMaker Server 16, but it's a feature that's been around for a few versions.

             

            c. The path is on a local drive (no fancy external drives or unsupported shenanigans like shared network folders, I mean who uses those in an office anyways)

             

            We have restarted the server already.


            Anyone seen & solved this?

             

            Thanks!

            Could it be as simple as not having a "slash" at the end of the folder path?  Leaving that off sometimes can cause problems.

             

            Steve Romig

            FileMaker, Inc.

            • 3. Re: FMS 15 - Additional Database Folders does not work.
              taylorsharpe

               

              Could it be as simple as not having a "slash" at the end of the folder path? Leaving that off sometimes can cause problems.

               

              Steve Romig

              FileMaker, Inc.

               

              Or could be a little more complicated like not having correct permissions to the folder or the path is different from this server.

              • 4. Re: FMS 15 - Additional Database Folders does not work.
                user19752

                I saw same issue, and thought it is a bug of admin console, since

                a. The validate path button does nothing. You click it and it's like clicking on a picture. It's basically in a coma state. Other areas of the console work, properly.

                 

                Clicking "validate" or "save" buttons did nothing (but POSTed something, seeing browser network console of IE) when entered path is valid or invalid (clearly invalid for example only one character "1"), "revert" and "save" buttons were kept enabled. "revert" worked. OTOH if path is empty it showed error message.

                • 5. Re: FMS 15 - Additional Database Folders does not work.
                  PeterDoern

                  I have the exact same issue on FMS 16.

                   

                  Hard drive is partitioned into C: (OS and server proper), D: (Data) and E: (Backups).

                   

                  When I installed server last week I successfully created Additional Database Folders on D:, and this is is where the database files are residing.

                   

                  At the time I also successfully created a Progressive Backup folder on E:.

                   

                  Today, I tried setting up a backup schedule to drive E:, which threw the Invalid Path error. So I tried setting the default Backup Folder in Database Server > Folders, which also threw the error.

                   

                  I notice also that I'm unable to disable the Additional Database Folder 1, although perhaps this is by design.

                   

                  I have rebooted the server itself and also restarted Admin Console via the command line, but otherwise could use some guidance.

                   

                  Thanks,

                   

                  Peter

                  Screen Shot 2017-06-30 at 7.43.18 AM.png

                   

                  Edit: tagged TSGal to see if we can get some expert eyes on this. This isn't a case of a missing backslash. A path that worked at set-up no longer works.

                  • 6. Re: FMS 15 - Additional Database Folders does not work.
                    PeterDoern

                    After my third re-install of FMS I added a folder to E:/FileMaker Server/Backups/ so that the full path was now E:/FileMaker Server/Backups/All/

                     

                    This works. Don't ask me why it needed another layer of directory but it did. Anyway, I'm happy to say that this fixed my problem. Maybe it will help you, ADNPlus.

                    • 7. Re: FMS 15 - Additional Database Folders does not work.
                      ADNPlus

                      Thanks to all so far. We're on a brutal production schedule so little time is left to deal with these bugs and we have to attend more comprehensible though still important issues.

                       

                      First concern for me would be -  why the Validate button sits there doing nothing? Regardless of what the path is. I expect the console to fail or pass my path value. What is most distressing is that it doesn't react at all. If I will be put on the frying pan, let it be after putting the damn dysfunctional feature first.

                       

                      I ran into a similar situation as Peter when trying to setup progressive backups at one point. I had to reinstall the FileMaker server then as well for no other reason than this. I hated every minute of it. It's a production system, people need to be plugged pretty much 24/7 and top management, as well as I, expect that they can rely on the platform as much as possible.

                       

                      So far reinstalling FMS seems to be what I will have to do again. But now that 16 is out, I will might as well do that instead, which means I have to upgrade countless users to newest compatible version of FMPro. See how easily this ridiculous issue messed up my schedule? Grrrr. I'll get back to this as soon as I have some time.

                       

                      Go Fiiemaker and Vive La France!!