AnsweredAssumed Answered

Problems scheduling system script on Mac

Question asked by smith7180 on Jun 30, 2017
Latest reply on Jul 1, 2017 by jonmyrah

Most of my servers are Windows vm's on AWS.  I have system scripts that send backups to S3, and they've always run without a hitch.

 

I have a client with a mac mini server, and I have desperately struggled to get the shell script that sends backups to an external drive to run.  Initially I was advised to schedule an applescript which in turn runs a shell script.  The idea, if I understood correctly, was to avoid the permissions issues that are the bane of my existence when I'm servicing this mac mini.

 

I was not able to get that to work, however after changing the permissions on the shell script with Batchmod, FMS would run the shell script directly.

 

The client has recently switched from an external raid connected via USB to network attached storage and now FMS will no longer run the shell script.  I'm once again stuck with an applescript and a shell script that always get the 'aborted by user' error message in FMS.

 

The owner and group of the folder on the NAS is listed as "unknown," and batchmod cannot change this.  I'm guessing this is what's causing the issue?  If I manually run the applescript, everything works fine.

 

I've tried every combination of privileges with Batchmod, and I've tried running the scripts in FMS with accounts other than FMServer.  I can't get anything to work.  I'm guessing my next step is to have a third party program schedule the applescript, but before I take that step I wanted to see if anyone in the community had any suggestions.  I'm not familiar with scripting on OSX, so the only error message I can offer at the moment is "Aborted by user".

Outcomes