4 Replies Latest reply on Jul 20, 2017 9:58 AM by TSGal

    FileMaker 16 - WebViewer - GetLayoutobjektAttribut

    waechter

      The function GetLayoutobjektAttribut("WebViewerObjectName", "source") is not returning the full / correct URL under some conditions.

       

      Under normal conditions this function returns the URL including the anchors for example "http://example.com/#someInitialAnchors". But if a FileMaker Script changes the URL of this Web Viewer via the script step "Set Web Viewer" goto URL: "http://example.com/#aNewAnchor", the function GetLayoutobjektAttribut("WebViewerObjectName", "source") ist not returning the correct URL anymore.

       

      With the previous FileMaker Versions 12, 13, 14 and 15 there was no Problem with this function.

       

      Tested on:

      Mac OSX El Capitan Version: 10.11.6

       

      FileMaker Pro 16.0.1.162 Advanced: is not working

      FileMaker Pro 16.0.1.162: is not working

       

      Tested with older Versions:

      FileMaker Pro 15.0.1.119 Advanced: is working

      FileMaker Pro 15.0.1.119: is working

      FileMaker Pro 14.0.5 Advanced: is working

      FileMaker Pro 14.0.5: is working

      FileMaker Pro 13.0v4 Advanced: is working

      FileMaker Pro 12.0v5 Advanced: is working

       

      I attached an Example of this Bug: Open the FileMaker Document and push the Button "Set New URL (Push ME!!)" to test the behavior of this Bug.

       

      It would be great to get a quick Bugfix. Feel free to contact me for further information.

       

      Kind regards

      Julian