1 2 Previous Next 15 Replies Latest reply on Jul 21, 2017 6:36 AM by TSGal

    Customize Status Toolbar still not fixed

    dburnham

      This issue began appearing in FileMaker 14.  It was reported in 14 and 15, and intermittently seems to have been fixed but it keeps coming back like a bad penny.  Or worse than a bad penny, maybe a bad nickel that is 5 times worse.

       

      I don't want to work with the standard toolbar icons when I am doing development work.  I don't want to accidentally create or delete records.  All I want to see is Manage, Data Viewer, and Debugger.

       

      Every time I use Customize Status Toolbar, I get the satisfaction I want for a few days and then, without any warning the default set is back again.

       

      And it only happens in Browse Mode.   The customized tool bar I made for Preview Mode and Layout Mode do not vanish.

        • 1. Re: Customize Status Toolbar still not fixed
          TSGal

          dburnham:

           

          Thank you for your post.

           

          I found your original report and your contact with one of our Support Technicians.  Although neither Development nor our Support Technician could reproduce the issue, Development did mention the customized Tool Bar setting is stored in the com.filemaker.client.advanced12.plist in your user Library Preferences folder.  If you delete this file, you should be fine.

           

          Since this issue continues to occur, does this generally occur with a specific file?  If so, are there any Custom Menus being used?  Any other information you can provide may be helpful in reproducing the issue.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: Customize Status Toolbar still not fixed
            dburnham

            Thank you so much for this reply.  I have deleted that preference file, and if henceforth the problem goes away then you are eligible for the biggest thank you I can offer via this discussion thread.   In person, it could be worth either a hug or flowers or both.

             

            I can tell you that the problem has manifested across all databases and was completely random in its sudden appearance and I have never been able to keep my eyes focused on the status area after each and every click or filled entry, especially when the status area is open and closed so often during the course of my work.  That is, I open it when I need to do developer-only work, whereas various scripts keep it closed for users.

             

            Having discarded the plist file, I will do a restart and advise further the next chance I get.

            • 3. Re: Customize Status Toolbar still not fixed
              dburnham

              Sorry to report that the issue has not been resolved by deleting the PLIST file.  After I restored all my Host addresses and file names, I went out to dinner last night and did not do any work on the file that was open on my computer overnight.

               

              This morning, I did a little bit of work on the file, including running a DDR report that I imported into Base Elements.  I did some more work on some scripts and now, as I look at one of the windows in Browse mode, the default buttons are there again.  This is exactly what I have been complaining about since version 14.   In Preview Mode, the detaults have re-appeared also.  In Layout Mode, it's the same:  the button for New Layout has re-appeared but the Manage button is still there because it is a member of the Defaults.

               

              Forgive me if I am mistaken but I think these settings may not be stored in that PLIST file.  I've looked at it in a text editor and I don't see any references to the toolbar that would given its behavior.  Maybe I just don't know what to look for.

              1 of 1 people found this helpful
              • 4. Re: Customize Status Toolbar still not fixed
                dburnham

                Just to be complete about it, I made sure that closing the file and re-opening the file doesn't cause this to happen.  It doesn't.  At least not in the attempt I made 4 minutes ago.

                 

                Opening a New Window to the same database doesn't do it either.

                 

                I have Developer Assistant running all the time as a plug-in I can't live without.  I ran a few searches of scripts in DA and it doesn't affect the toolbar settings either.

                 

                Toggling in and out of Layout Mode doesn't do it either.

                 

                Toggling the Status Toolbar doesn't not cause it.

                 

                Opening another database does not do it either.

                 

                Sure wish I knew what causes it -- I would stop doing that if only I knew.

                • 5. Re: Customize Status Toolbar still not fixed
                  dburnham

                  Here's a new phenomenon.  After writing the previous message late last night, I went to sleep -- left the databases open on my computer.   Didn't touch a thing except to look at them this morning.  And look:  one of the open windows has an extra Debugger icon in the status toolbar.

                   

                  Never seen that happen before.  Ever.

                   

                  Screen Shot 1.png

                   

                  And then, when I went to that window and toggled into  layout mode and back to Browse again, the second debugger icon disappeared.

                   

                   

                  ===== UPDATE ===

                   

                  An hour after posting the above remarks, the default buttons have returned.  I swear I have no idea what I might have done in the interim to trigger this.

                  • 6. Re: Customize Status Toolbar still not fixed
                    TSGal

                    dburnham:

                     

                    Neither our Development nor Testing departments could reproduce the issue, and they have requested a copy of your database file.  I have sent you a private message with instructions where to send the file.

                     

                    TSGal

                    FileMaker, Inc.

                    • 7. Re: Customize Status Toolbar still not fixed
                      dburnham

                      There isn't "the file" in regard to this.  It applies to any and all files that I ever open.   I think what I will do to help you analyze this is I will use a starter solution and send you that file, together with the PLIST file after the problem manifests itself. 

                       

                      May I also add that the most important reason to fix this is the same thing I reported in FileMaker 14.  The location of the DELETE RECORD button is dangerously close to the position of the PERFORM FIND button when any user, not just me, is using the default status toolbar icons.  What happens is this:

                       

                      A FIND is performed and suddenly, a dialog box appears asking if you really want to delete the current record.  This alarms people -- including me -- because I have no recollection of doing anything that would delete a record.  If I am not careful to choose "Cancel" the record is irretrievably deleted.

                       

                      I get phone calls from users who ask me why they are being prompted to delete a record when they did nothing to choose that command.  The reason is the sticky mouse click on the place in the status toolbar where Perform Find is located.   The defined region for those buttons must be overlapping.

                      • 8. Re: Customize Status Toolbar still not fixed
                        TSGal

                        dburnham:

                         

                        Which Starter Solution are you using?  I will test that Starter Solution.

                         

                        TSGal

                        FileMaker, Inc.

                        • 9. Re: Customize Status Toolbar still not fixed
                          dburnham

                          I think you misunderstood me. 

                           

                          I was trying to explain that this issue with the status toolbar is persistent no matter what database I am using.  I could choose any one of hundreds of databases and send it to you and it would only introduce more confusion by having to detect something in my database.

                           

                          Since it happens on any database that I use, I was suggesting that I open one of the Starter Solutions and I will edit the toolbar in that file and then when I see the toolbar icons change back to the default, I can send that file to you along with the PLIST files.

                           

                          I've been too busy since 7AM to do it today, but I will have time this afternoon.

                           

                          For starters, here is the customized status toolbar in the Contacts file that I just opened.   In addition to Browse mode, I also modified layout mode and Preview mode.

                          Screen Shot 1.png

                           

                          thanks again!

                          • 10. Re: Customize Status Toolbar still not fixed
                            dburnham

                            I went out to see Spider Man at 6:00.  I left the Contacts database open on my computer.   It is not the only database open on my computer.  Two of my own database are also open.

                             

                            When I came home from the movies and looked at my computer, one of my databases had 2 Debugger icons in the toolbar.  I put it in Layout Mode and then back again to Browse mode and the second Debugger icon was gone.  But in its place, there was a SHARE icon that I have never added to my toolbar.

                             

                            So I then looked at the Contacts database that was minimized while i was away from home.  Its toolbar was in the same customized state I had made for it (see earlier message above.)   I thought that my preference should take effect on all databases, but the SHARE icon was not in CONTACTS.fmp12.   So I opened Script Workspace and performed two of the 3 scripts that come with the starter solution:  the "open" script and the "Sort Contacts List" script.  Note: I did not close the file, I just ran those scripts with the already-open file.   And guess what:  the SHARE icon now appears in Contacts, too.   And the QuickFind search field is all the way over on the right, instead of right beside the Debugger icon where I had located it by replacing the variable spacer thing with the smaller fixed spacer

                             

                            Screen Shot 3.png

                             

                             

                             

                            P.S.  Spider Man is a really dumb movie.

                            • 11. Re: Customize Status Toolbar still not fixed
                              TSGal

                              dburnham:

                               

                              I received your file.  Thank you.

                               

                              Yesterday, I installed your "Bad PLIST file.plist", renaming it appropriately, launched FileMaker Pro Advanced 16.0.2, opened your Contacts.fmp12 file, and left it running overnight.  This morning, I still see your custom Toolbar.

                               

                              I will be working with several files today, and I'll continue monitoring the custom toolbar.

                               

                              TSGal

                              FileMaker, Inc.

                              • 12. Re: Customize Status Toolbar still not fixed
                                dburnham

                                I've been away from home for much of the past week, including a death in the family, so I have not been as conscientious about this as I hoped to be.   But I do want to report back to you that for the last several days the toolbar has remained consistent.

                                • 13. Re: Customize Status Toolbar still not fixed
                                  TSGal

                                  dburnham:

                                   

                                  My condolences to you and your family.

                                   

                                  Thank you for the update.  I am still using your plist file, and after starting my computer this morning and launching FileMaker Pro 16.0.2, I still see the same options/icons in the Toolbar.

                                   

                                  TSGal

                                  FileMaker, Inc.

                                  • 14. Re: Customize Status Toolbar still not fixed
                                    dburnham

                                    Thank you ....

                                     

                                    Throughout this week, I have had no recurrences of the reported symptom.  Just a moment ago, the default icons re-appeared in my status toolbar.  Only a few minutes ago, my chosen buttons were the only ones present.  To the best of my recollection, here is what has happened in the past few minutes.

                                     

                                    I was debugging a script after the first running of the script did not satisfy me.  During the progress of that script running, that is to say, while it was running, I turned on Pause on Error which is something I seldom do during the running of a script but certainly do at other times when a script is not running.

                                     

                                    The step I was debugging is a Perform Find script.  To solve my script error, I changed layouts and performed the script manually in a table view.  Then, I returned to script workspace to modify the variables I had defined in order to perform the find with correct results.  I then saved the script and renamed it to reflect today's date, which I always use as the prefix of ever script name because that is the only way to see the modified date of scripts in the sidebar list.

                                     

                                    I then returned to the original layout and when I looked at the Status Toolbar to open the debugger for re-running the modified script and the screen shot below shows you that my Debugger and Manage and Data Viewer icons are gone and instead the full set of defaults is present as you can see below.  The PLIST file is attached.

                                     

                                    Screen Shot 1.png

                                    1 2 Previous Next