4 Replies Latest reply on Jul 13, 2017 12:41 PM by ddave

    "The account and password you entered cannot be used to access.... "

    ddave

      Hello,

       

      I have been working on a database hosted on server. It was built a while ago. (it is fmp12 file)

       

      Now , the layout I am trying to access is based on "wip" table and the database name is "wip"

       

      The layout is using some fields from other databases. I have attached the relationship screenshot for this database.

       

      Screen Shot 2017-07-13 at 9.36.35 AM.png

       

      It is using identical account name and password (Full Access Privilege) for every database it is related to.

       

      Now the user flow for this solution goes : (database and table names are similar)

      1. User opens a layout in "Mainmenu" database (File -> Open Recent )

      2. Clicks on one of the buttons to go to a form layout based on "wip" database

       

      when you go from first to second step, it always asks for credentials: (in which the account name is pre-populated with system username)

      This happens only when you open the file first time after opening filemaker client. 

      Screen Shot 2017-07-13 at 10.54.05 AM.png

       

      When you enter valid account name and password for the "Customer" database, it throws this error:

       

      Screen Shot 2017-07-13 at 10.37.05 AM.png

       

      If I press cancel, it opens the layout with all the related fields missing. The "Customer" database file has File-option set to login using the same account but I tried to disable and enable it , didn't have any success. Is there any way I can disable this dialog box asking for credentials ?

       

      Another thing I have found is when I open the customer database file manually and then try to reopen the layout, it bypasses the dialog box and populates all the related fields ok.

       

      I could create a script and open the customer file first when user clicks the button and close it and then redirect user to the layout but I want to know why this issue happens.

       

      The machines are using MAC OS X 10.12 and Filemaker Pro 14 and Server using MAC OS X 10.11, FM Server 13

       

      Thanks

        • 1. Re: "The account and password you entered cannot be used to access.... "
          philmodjunk

          Sounds like the file does NOT have an account with matching account name and password. Perhaps the password was capitalized differently or some other small difference is at work here. Keep in mind that FileMaker makes User Names and Account Names a confusing topic. Account names are specified in Manage Security and are what you need to enter to log in to a file. User names are specified in Edit Preferences. But then FileMaker confuses the topic by automatically entering the current User Name as the default Account name when the password dialog opens. So sometimes people think that they have the account name that they need when what they actually have is a user name that does not match to an account and they get an error until they figure out that the need to change the default to an account name that actually works.

           

          These are just guesses, but odds are very, very high that you have a file that needs to open that requires credentials different from what was used to open the first file and that is different in some way from the credentials that you are trying to use to open it.

          • 2. Re: "The account and password you entered cannot be used to access.... "
            ddave

            I have been using correct Account name (not user name) to enter and I have reset passwords and also deleted and created new "Full Access Privilege" accounts for both the databases but neither of them worked. I tested if I entered the correct password by accessing the actual "Customer" database file. So it lets me open the Customer database layout with the same credentials.

            • 3. Re: "The account and password you entered cannot be used to access.... "
              philmodjunk

              It's unlikely, but the file could be damaged. You could pull a copy down of the server and run a recover on it to see what is reported.

               

              Make sure that the copy of the file on which you are resetting the password is the same copy that the system is trying to open. Not trying to insult you here, but sometimes you have another copy floating around and the external data source refers to it instead of the copy that you think you need to open, have to check for the obvious "oopses" along with the more esoteric ones.

              • 4. Re: "The account and password you entered cannot be used to access.... "
                ddave

                After digging in a bit, I found out that the database was related to external data sources with three file paths and one of them using "*" (wildcard) path. The first path was pointing to the file in developer's local windows machine (dev's mistake) and second was set as fmnet:/*/Customer which I changed to fmnet:/HostIP/file location suggested by filemaker original documentation and that worked.

                 

                Reference: Creating file paths

                 

                Learned something new