lmack

Some records invisible after table-table import

Discussion created by lmack on Jul 19, 2017
Latest reply on Jul 19, 2017 by philmodjunk

I'm writing a script to manage two sets of employees - active and those that have left (but records need to be preserved because they might come back and because some of their data feeds into historical records of the institution).

 

I've created a separate table for the employees that have left. I've tried two different ways of writing the script and also just manually performing an import and the result is always the same: some records are imported just fine every time while others are imported as ghosts every time I try: a record is created but I can't see any data.

 

I know some data is in there because, when I sort by ID number, the invisible/blank records sort with the visible records correctly according to their ids. Also, when I try to import one of the invisible records a second time, validation stops me because I set up the ID number field as a unique value.

 

I don't think my script is the problem, because the manual import produces the same result. I also checked to see if the problem was only with older records but, judging by the ID numbers, when the record was entered doesn't seem to be the deciding factor.

 

The only clue I have is that, when lining up fields to import, some records match perfectly (the fields in the two tables are identical) and some have a <field missing> line at the top that appears to put data in the wrong fields. I haven't been able to find an explanation of why this is happening.

 

This database was recently converted from FMP 5 through FMP 7 and it's now in FMP 14. Could this be a side effect of the conversion process? Is some of the data corrupt?

 

I've been tearing my hair out all day. Any help is most welcome!

Outcomes