0 Replies Latest reply on Jul 21, 2017 12:32 PM by justinc

    FMS 15.03 backup folder permissions change after error 685

    justinc

      I have run across an odd file permissions problem recently.  This is on a machine running FMS 15.03, Windows 2012 R2.

       

      I use Remote Desktop often to administer our servers.  I have left a File Explorer window open to a backup directory after copying it out of that folder.  I then log out of the machine, leaving the folder opened on the desktop (i.e. I just close the connection, I don't log the user out of the remote machine).

       

      Then, a couple of days later I start to get errors from FMS that it can't delete a backup folder - the one that I left the File Explore window open in.  OK, makes some sense.  I remote desktop into the machine and close the File Explorer window.  But, then I still get errors from FMS that it can't delete the folder.  OK, so I go back to the machine and attempt to delete the folder manually.  I get an error message saying that I need permissions to delete this folder.  This user that I am logging in with an administrator account.

       

      So I tried opening a shell prompt in 'administrator mode' and deleting the folder that way - no luck.  It doesn't give me an error, but it doesn't delete the folder either.

       

      As a test of the normal folder permissions for these backup folders, I ran a Schedule to create a new folder and then tried to delete it in File Explorer.  I was able to delete it without problems.

       

      So something appears to be happening to the folder permissions when FMS tried to delete it but can't, and now I can't delete the folder.  The permissions on the folder look like I should be able to delete them.  These 'failed' folders are now marked as 'Read Only' but when I try to change that, I get more errors saying 'access denied'.  I have tried changing some permissions on the file, but get similar 'denied' errors.

       

      My last thought is to reboot the system, but I haven't found a spare opening in the server usage yet, and don't know if that will work, anyway.

       

      Anyone else know what's going on here?

       

      Thanks,

      Justin