AnsweredAssumed Answered

Insert from url ftp and curl options problem

Question asked by Gingernut on Jul 25, 2017
Latest reply on Nov 14, 2017 by MichaelHeider

As an intro I can do filemaker but this ftp is all new to me - (as was XSLT but I cracked that over the weekend)


Using Windows and Filemaker 16.


I am trying to add a file (Purchase order xml) to a suppliers ftp server. I keep getting Authentification failed Error 1627 but the details are definitely correct. I have copied and pasted them from ftp programme which does connect.


I have placed my xml file in the container field ( should this be encoded text if it is an XML file - seen that mentioned on another post.


This is my script -


Set Error Capture [On]

Set Variable [$$result;Value “”]

Set Variable [$usr; Value:”username” ]   NB the Username has spaces in it – Could this cause a problem?  It is in the format xxxxx - xx

Set Variable [$pw; Value:”password” ]

Set Variable [$file; Value: Interface:container]  NB I have put the file in the container NOT with a stored reference - is that bit correct - I have tried both

Insert from URl [Select; With Dialogue;Off; $$result;
& GetContainerAttribute (interface:container:;

cURL options;”—user “ & $usr & “:” & $pw & “
–T $file”



As well as -T I have tried and --upload-file.


The only thing I can think is causing a problem is the spaces in the Username but don't have to do anything different if I try ftp from the Windows command  prompt -(just type with the spaces.)


It does get as far as showing "URL data transfer transferring file " which makes me even more confused.


Please help as I have spent 2 days trying and reading everything I could. oettelshoven kindly gave me pointers as above but still not getting through.