12 Replies Latest reply on Aug 1, 2017 1:15 PM by FileKraft

    PSOS not working

    user12569

      All,

       

      I installed Server 16 along with a worker machine.  One remaining issue; however, is that PSOS does not work.  What would cause this?  I have tried everything for quite some time short of uninstalling server and reinstalling....hoping that is not required.

       

      Any thoughts or experiences with this?  I saw a forum discussion on this topic from a while back, but it wasn't answered. 

       

      Thanks in advance for any thoughts if you have ran into it before ...

        • 1. Re: PSOS not working
          BruceRobertson

          Do you thoroughly understand how to use PSOS?

          You have used it successfully before?

          There are a lot of details you need to understand.

          • 2. Re: PSOS not working
            CarlSchwarz

            You may want to make a blank file to check PSOS and do something incredibly basic like

            Go to layout ( simple)

            New Record

            commit record

             

            If you see a new record created then PSOS has worked.

             

            When you call PSOS all of the file / layout triggers are called, e.g. "on first window open", and the PSOS script is run as a new user on the server.

            1 of 1 people found this helpful
            • 3. Re: PSOS not working
              fmpdude

              Bruce, it would be helpful if you would list relevant details rather than just allude to them.

               

              With the current FMS pricing "model", I don't use FMS so I have no way to actually test PSOS.

               

              But, I often wonder if the PSOS means you have a "stored procedure" equivalent in FMS like other databases have giving you common set of functions you can call across ALL your FMP applications in FMS.  That is, a top-level globally available function library.

               

              A generic explanation of the different types of PSOS with a small example of each time beyond the FileMaker documentation would be useful.

              1 of 1 people found this helpful
              • 4. Re: PSOS not working
                philmodjunk

                A) not all script steps are "server compatible" so check it for compatibility in the scripts workspace

                 

                B) as mentioned earlier, any triggers set in File Options will be tripped

                 

                C) the client context at the moment PSOS call is made (what layout, found set, current record...) is not available to server side session. That script has to reproduce that context using only what you write into the script and pass as a script parameter.

                 

                D) any data in variables or global fields are not accessible to the script. This data needs to be sent to the script in a script parameter also.

                • 5. Re: PSOS not working
                  user12569

                  Yes. PSOS for same batch of solutions worked flawlessly on server 15.

                   

                  This message was sent using voice recognition on a mobile device.  Please excuse any errors.

                  • 6. Re: PSOS not working
                    PeterDoern

                    If yours is a multi-file solution note that all files referred to in the server-side script must be opened locally first. Apparently the server-side script doesn't know to open the files itself.

                    • 7. Re: PSOS not working
                      philmodjunk

                      Given that the scripts worked in a previous version, you might do as previously recommended and set up a very simple use of PSOS to check to see if it is working at all for you.

                      • 8. Re: PSOS not working
                        JonThatcher

                        Look in the Event.log for messages when you try to run PSOS. This would show the exact step causing the problem if it's an incompatible step issue. You can also see whether there are messages about the FileMaker Script Engine process terminating abnormally or you can confirm that the process was started.

                         

                        The Event.log is your friend! :-)

                        3 of 3 people found this helpful
                        • 9. Re: PSOS not working
                          user12569

                          Thank you for your comments everybody. The issue would not have been with the scripting nor the logic in the files. I ended up having to reinstall the server and that solved it perfectly. Although, I am not sure why that was ultimately required. Moving the files over after reinstalling resolved everything.

                           

                          This message was sent using voice recognition on a mobile device.  Please excuse any errors.

                          • 10. Re: PSOS not working
                            user12569

                            Just an update for everybody:  the server admin had modified the hosts file in the windows/sy../drivers/etc/hosts location to point the public URL back to localhost. 

                             

                            This was a real problem for some of the PSOS steps.  After a few of them racked up, it would cause the server to become unresponsive. 

                             

                            Needle in a haystack    Thanks for your comments...

                            • 11. Re: PSOS not working
                              philmodjunk

                              This reads like a classic example of a problem that occurs when a past process that worked perfectly before stops working. The easy question boils down to "what changed"? Finding the correct answer to that question, however, isn't always easy.

                              • 12. Re: PSOS not working
                                FileKraft

                                is there a latency issue you might have experienced? how about a Pause of 1 sec in your script?

                                run into this that PSoS was to fast and previously created records not yet available - ( Flush Cached Results not supported as a Server executed script step ).